Issues downloading miniconda3 on macOS Catalina

Hello, I don’t think there was a post regarding issues with zsh shell script so I figured I’d start a thread to get some feedback.

I was beginning the exercise on Brute Force Linear Regression here and having trouble getting miniconda3 to work on macOS Catalina. None of my conda commands would work on the terminal after installing. I think the installation process was interrupted somehow, causing it not to initialize?

I found a couple possible issues after some digging, hopefully someone can verify I’m on the right track:

  1. newest stable version of python is 3.8.4rc1, and (I think) is not compatable with miniconda3 – only versions 3.7 seem to work based on some other threads. I had to download 3.7 and make sure it was the default version (not 3.8). I checked using:
which python

or
python --version

  1. since the default shell script on macOS Catalina is zsh instead of bash, I found the following steps are necessary here Essentially, there are 2 additional commands that need to be entered in the terminal before miniconda3 can work properly:
source <path to conda>/bin/activate

and

conda init zsh

After performing those 2 steps, I was finally able to use conda-related commands in the terminal.

If anyone can clarify on or confirm the above issues due to zsh shell script that would be great!

2 Likes

Thank you for sharing the details :+1:. I’ve not tried using conda for a little while but if I get the chance I’ll run it later today. I do think a few others have had issues along the same line; @lisalisaj is this what you ran into as well?

It seems the conda install defaults to altering the bash profile rather than the zsh profile which would be a problem for those using Catalina (I think zsh is now the default) since you wouldn’t have conda/anaconda added to the path.

If you were really determined to use both 3.8 and conda there’s a couple of loose suggestions about installing python 3.8 normally and using conda to create a virtual environment specifying the 3.8 install. None too sure if there’s any benefit to using conda to do this and you might end up messing up some dependcies (you’d have to look into it) so perhaps using your own environments for 3.8 would be a better shout.

1 Like

Yes, that’s it.
I followed this article & it fixed my issue. I don’t use conda or navigator anymore. I just initiate jupyter notebook in my terminal window. Or, even better: I use Colab.
https://medium.com/towards-artificial-intelligence/how-to-run-jupyter-notebook-on-macos-catalina-in-four-steps-f7cc4e2cc270

3 Likes

There’s also this thread if you have Jupyter issues:
https://discuss.codecademy.com/t/jupyter-notebook-errors/509820

1 Like

I’ve followed the medium link How to Run Jupyter Notebooks on MacOS Catalina — in Four Steps. But after I entered yes, zsh indefinitely run y. Why is that? And my computer became super hot. So I just exited the terminal. And reopened it. Just follow the next step: Set-up macOS Terminal with Zsh. Did you encounter the same issue?

One more question: when I followed the article in step 2.

When I did that, the terminal showed:

So I googled it, and here’s a thread about it:https://stackoverflow.com/questions/29910217/homebrew-installation-on-mac-os-x-failed-to-connect-to-raw-githubusercontent-com

I followed one of the suggestions written:

However, permission was denied.

Moreover, code --install can not be reinstall.

Did you encounter the same problem? I don’t know how to move on to the next step. Could you help me out?

Could you take a look at my problem? I encounter exactly the same issues:

That’s why this thread leads me here.

I followed lisalisaj’s recommended article but got stuck at step 2 as described above.

I also followed your advice to follow the steps in https://docs.conda.io/projects/conda/en/latest/user-guide/install/macos.html. But sth’s wrong about the installation, which I forgot to screenshot, so I don’t remember the exact word.

However, when I tried typing ‘conda list’ one more time, it shows:

While I type ‘jupyter notebook’, it shows:

It seems like I’ve installed Jupiter notebook. But frankly, I have no idea how all these happened and why. It’s very confused.

No, I did not encounter that issue.
So, you quit the process and then skipped ahead to the second step w/o completing the first step?

No. Step 1 is smooth, I don’t have any problems with step 1.

It’s not something I can check these days as I don’t have access to OSX at the minute. I’m not sure if those instructions are a little dated or not because you don’t really need to do most of them. Installation of anaconda will provide you with a new Python distribution and it will include Jupyter from the get-go as one of the pre-installed Python packages (with Anaconda not with the cut-back miniconda).

From what I can tell you’ve installed anaconda and are using the python distribution that comes with it to run the jupyter notebook package that also comes with it (anaconda).

Installation of homebrew (package management, similar to macports) isn’t strictly required, nor is installing iterm2 (a different option from the built-in terminal app) nor is changing the default shell for this new installation and you certainly don’t need to install oh-my-zsh even if it is quite nice. These are all things you might want to do but you don’t need to do them.

2 Likes