Issue with pushing the remote repository

Hello there!
I’m on the: https://www.codecademy.com/journeys/full-stack-engineer/paths/fscj-22-building-interactive-websites/tracks/fscj-22-git-and-github-part-i/modules/wdcp-22-introduction-to-github-beddaab4-bbb4-4be7-ba2d-76e9743caac7/articles/getting-started-git-and-github part.
Trying to set up Git and GitHub and push my first repository on GitHub.

I have created also, Fine-grained personal access token and saved on my notes the password.
I was following the steps carefully added username and password(pasted as password the token) then error : remote: Permission to danank1/git_newpractice.git denied to danank1.

fatal: unable to access ‘danank1/git_newpractice · GitHub’: The requested URL returned error: 403

Cannot understand how to fix this! I’m using MAC OS. Any help would be valuable thank you :slight_smile:

This looks outdated. Normally you use SSH keys to connect with github.

If you follow the github.com instructions it should work.

1 Like

thank you so much!, you saved me
I had to do a bit more research but I was able to fix it.

1 Like

I was having the same problem, using SSH worked

Update?

1 Like

it worked! It would save me time if it was included earlier in the course!

1 Like

I should’ve included that the “update” part was for Codecademy, it would be helpful for newbies who wouldn’t know how to fix it unless we searched :slightly_smiling_face:

I just couldn’t figure out how to tag the Codecademy team

1 Like