Is there a shortcut to go to next task?

The “Cmd + Return” shortcut to “submits the code in an exercise” is still not working on Mac!?

@ryan or @stetim94

It seems like Ryan compiled these shortcuts in 2014.
I’m on Mac, and I cannot seem to load next exercise with Ctrl + >

I’ve also tried similar shortcuts like Cmd + >, Alt + >.
None worked.

Any suggestions on how to load next exercise in 2019?

1 Like

the topic seemed to be updated in February, but i can’t seem to get it to work either. Let me ask around

1 Like

I too would love to be able to go to next exercise without needing to move my mouse. FreeCodeCamp allows you to go to next exercise with the same shortcut of submitting code and it’s really useful.

Needing to move my hands to use my trackpad is so little yet so annoying.

1 Like

I’ve been trying to make this shortcut work for a while! I don’t understand what key combo I need…Alt+> and Alt+Shift+. (where the > key is) both don’t work…

1 Like

any updates to this? I understand there’s more important things to do but this would be really helpful

Unfortunately there is no update.

These shortcuts work on certain courses or lessons and don’t work on others.

Yes, Codecademy developers prioritize work and bugs would be at the top.

I hear you :slight_smile:

Hey all—I’m VERY EXCITED to share a surprise update on this:

Shortcuts are back!

Mac:
cmd + return: submits the code
ctrl + g: resets the code
ctrl + >: loads the next exercises
ctrl + <: loads the previous exercise

Windows:
ctrl + enter: submits the code
alt + g: resets the code
alt + >: loads the next exercises
alt + <: loads the previous exercise

5 Likes

Thanks for the update!

Just wanted to confirm if it’s actually ctrl + >/ctrl + < on Mac, because mine works on ctrl + ./ctrl + , instead (I like it better this way though!)

I’m on a Mac and the shortcuts that work for me are ctrl + . and ctrl + , (i.e. you don’t need to press shift).

1 Like

Also, note that the shortcuts won’t work if the focus is on the terminal (i.e. if you can type code in the middle window). To remove focus from the terminal, just press esc.

4 Likes

Hi all, I’m on PC, and ctrl+> does not work for me. I’ve also tried ctrl+shift+> but to no avail. I’ve also made sure to try clicking outside the terminal and clicking escape first.
Any help here?

Hey there, I just checked in with the PM that re enabled hot keys—

Should be alt > on a PC.

Lemme know if that doesn’t work. :slight_smile:

I am working in the “Introduction to JavaScript” course and “alt >” is not working (on a PC).

1 Like

Thanks for the reply, Alyssa!
It doesn’t seem to be working. I’ve tried using alt + > and alt + shift + >. I’m using Chrome on Windows 10, in case that helps at all. To be sure I’m not missing anything, I’ve included the key I’m using below.

image.png

1 Like

Aha, so I figured it out. Clicking escape wasn’t actually getting me out of the ‘terminal’.

To be honest though, not being able to just click alt + > while still having the curor in the terminal seems a little useless. If I have to click outside of the terminal in order to use the keyboard shortcut, why wouldn’t I just click the ‘next’ button?

4 Likes

I was able to get it to work based on tahonick’s suggestion, but I had to click out of the editor (and clicking in the console area didn’t work, I had to click somewhere else). If ‘esc’ doesn’t work, this isn’t very helpful. I remember in taking past Codecademy courses when this worked previously, I didn’t have to click elsewhere.

Hi all! I was having trouble getting the “next task” shortcut working as well, but I developed a solution!

I found a Chrome browser extension called Shortkeys that allows you to create custom keyboard shortcuts - including running custom java script.

I made a new shortcut (ctrl + .) for navigating to the next task with this JavaScript snippet:

document.getElementById('discovery-next').click();

All that does is simply click the little “next” button at the bottom of the page.

You also have to change the activation settings to ensure that the shortcut will run while in a form field. I added a screenshot below.

2 Likes

You are a GOD, my friend! Thank you @ender1687 this worked for me! Note that I did have to active it for inside forms, like he said.

This topic was automatically closed 18 hours after the last reply. New replies are no longer allowed.