Intro to JSX, Hello World error messages

bug-reported
javascript

#1

[https://www.codecademy.com/courses/react-101/lessons/react-jsx-intro/exercises/hello-world?action=lesson_resume]

It’s a simple copy and paste but it keeps registering it as wrong. I have tried typing it out, copying it in and nothing is working. I even tried to log out in case that was the problem but that didn’t fix the issue either. Any help would be appreciated.


const h1 = <h1>Hello world</h1>;



Terrible First Impression
JSX Elements And Their Surroundings
#2

im having the same issue


#3

Im having the same issue


#4

Me too. I got the bug as well


#5

Yeah I’m having this issue too.


#6

Having the same issue. Won’t even let me skip/proceed. Stuck :frowning:


#7

I reported the bug, to get pass the exercise, just run the code several times, then a popup should show: having trouble? press get code, this will get you passed the exercise


#8

Any solution for this issue?


#9

same here, great start^^


#10

Yeah, this works, but the same issue repeats for all the following exercises…


#11

I reported the problem, i will let you know when there is an update


#12

I have this issue with every exercise. And if I hit ‘get the code’ for all of them, well, it kinda beats the purpose :slight_smile:


#13

yes, but when i wrote this reply, i didn’t know the problem persisted throughout the track, that is why i reported the issue, and will inform of any updates.


#14

I’m having the same problem. Had the same problem months ago when I tried it before. Surprised that the problem still exists- thought they would have worked the bugs out by now. Thanks for reporting it and looking into it.


#15

Same issue… makes the site almost unusable. :frowning:


#16

I am also having the same problem and have submitted a bug report on my own from the lesson. Similarly, this issue of the correct code not passing the run tests have persisted through other lessons. I have tried things like resetting progress of this course and clearing my browser’s cache and cookies but all, unfortunately, have not fixed the issue. Any update will be appreciated!

EDIT: I noticed that test.js is an empty file with no text. I’m curious, is it suppose to have something in it to test what we write?


#17

still broken. tried on firefox, chrome, IE. Also reported the bug before I knew it had already been reported.


#18

Any luck on a solution ?


#19

no, given i said:

and i haven’t given updates


#20

facing the same issue, is this resolve?