Install button still not showing up

thanks asciismoke. great catch. it helped!!!

I put the code in line 48 but still an error…Did you includejs/directives…see image
index.html is the view right?

For anybody who happens upon this error in the future, my problem was an extra brace in my installApp.js file. Here’s what it looks like now for diff purposes:

app.directive(‘installApp’, function() {
return {
restrict: ‘E’,
scope: {info: ‘=’},
templateUrl: ‘js/directives/installApp.html’,
link: function(scope, element, attrs) {
scope.buttonText = “Install”;
scope.installed = false;
scope.download = function() {
element.toggleClass(‘btn-active’);
if(scope.installed) {
scope.buttonText = “Install”;
scope.installed = false;
} else {
scope.buttonText = “Install”;
scope.installed = true;
}
};
}
};
}
);

i get the install-uninstall button after fixing source code of , i’ve been miss-placing those code not in the apropriate place which is <-- directives -->.
cheers :grin:

It worked!!! This answer should be at the top!!!

Hi guys! My problem is that, although all the buttons show up, only one can be pressed. Do you have any idea what the problem might be? The test let’s me pass, but I would like to know where I went wrong

This was also my problem, rogue semicolons. :+1:

I removed the semicolons after }
and it worked. Thank you!