Impossible to save bookmarks or reply in forums (in FF)

First, I have already searched around, and at least within the best of my ability, I haven’t seen this reported, especially because (I think) this is new (it didn’t happen to me before I think).

Information about the bug reported: it has more to do with accessibility in the UI, than with any course or content.

Summary of the report: I can’t save bookmarks or even post a reply/message in the forums from Mozilla Firefox (I now switched to Chrome to write this).


Reply in Forums:

Course URL: None as specified above. It is above the UI.
Steps to Reproduce: Open the CC forums on Mozilla Firefox and try to bookmark a message or reply (and send such reply).
Fix or Workaround: Swapping to Chrome (kind of forcefully :slight_smile: )
Please attach screenshots:

Gladly! And also a brief explanation to go with them.

First, I think this didn’t happen not too long ago, because I have some messages bookmarked on my profile and I have been replying in the forums, too (I mean, from my Mozilla FF, although now I am in Chrome for obvious reasons). Meaning it could be some recent update.

Now, let me tell you I just didn’t want to complain, so since I am learning this with you, I tried digging a little in the Dev Tools and I think I may have found either the culprit or at least something related to it, or maybe not and I am completely lost and this may be unrelated :smiley: But it is worth trying in case it helps…

Please check the images attached. When I open the modal in Dev Tools, I found that there was an attribute missing on Mozilla FF, specifically the aria-pressed="false", that appears in the element on Chrome but doesn’t appear in FF (please check both relevant screenshots).

On Chrome:

On FF:

I also noticed that something called ember seems to be used and I looked it up, it’s a JS lib/fw which means chances are this click should be processed by JS in the background., Now, if you process aria-pressed in the background, you may need the ariaPressed property of the Element interface. And here is the bad news: please see the “ariaPressed-compat-table” image. :frowning:

This property is not compatible with Mozilla FF. I suspect the JS may do some check in the background to see if the button is pressed maybe? And if so, maybe FF doesn’t “understand” that. This is all theory, of course, and could be utterly wrong.

Now, I know that paying a membership doesn’t make you the owner of the world and that we don’t have to be expecting everyone to make accommodations for us, but it could be nice if I could use this on Mozilla FF, because I’ve been using this browser for years and it is really my favorite for a lot of reasons.

Well, I posed the challenge with my problem, but can I contribute any idea? The only two things I can think of (provided that the problem is actually that property and not something else) is either:

  • using a button instead of div (although I know it’s not always practical to use it as a button for various reasons)
  • changing any possible check for ariaPressed to also do a different check that FF will “understand”, like maybe checking the disabled property or smth like that. Although I am shooting a little in the dark. But at least to also contribute ideas, not just problems.

Meanwhile, I will have to continue my path coursework and forum participation on Chrome, so I don’t need to be swapping browser all the time, but I will honestly hope this can be looked at.

Thanks for your interest on this.

Hi there.

The forums use a platform called Discourse, which is not developed by Codecademy.

I don’t think the issue is necessarily with the forums, as I’m writing this response using Firefox and all the expected elements are showing correctly for me. (Granted, I am using FF in the ESR channel so I’m not on the latest-and-greatest version.)

Have you tried the usual troubleshooting suspects - fully clearing your browser cache, flushing the DNS cache, etc?

1 Like

Haha, thank you, you are right!

I feel very dumb right now, as I invested at least an hour in preparing the bug report, and I didn’t do the one minute thing: the cache. I am now replying you from my FF. :smiley: :hear_no_evil:

Well, at least I practiced how to submit a bug report, I will stay with that :slight_smile: .

And thanks again for your time and direction!

1 Like

You really shouldn’t, tbh.

As you rightly point out you’ve gained a bit of practice in submitting a bug report, but I think that perhaps you don’t give yourself quite enough credit for what you did here.

You found a problem, went through code which isn’t your own (which isn’t easy a lot of the time!), found what you believed was the cause of the problem and provided a really comprehensive bug report off the back of it.

Keep up the good work. :+1: