@import “helper/variables” bug


#1

Hello guys.
I have a problem; @import “helper/variables” bug at codeacademy sass course.

@import "helper/variables";
@import url(https://fonts.googleapis.com/css?family=Pacifico); 
@import "helper/placeholders";
@import "helper/mixins";



.absolute{
position: absolute
}

h1 {
font-family: Roboto, sans-serif;
}

.banner {
font-family: 'Pacifico', cursive;
height: 400px;
background-image: url($lemonade-banner);
border: {
top: $border;
bottom: $border;
}

.slogan {
background-color: $translucent-white;
border: 4px solid black;
top: 200px;
left: 25%;
line-height: 200px;
@include dimensions
(50%,200px);
@extend .absolute;

span { width: 40%; left: 30%; @extend .absolute; }
}
}

.container {
font-family: 'Pacifico', cursive;

.icon {
display: inline-block;
margin: 2%;
border: $border;
@include dimensions(300px, 300px);
}
}

Error: "Did you import the variables in main.scss?"
I can't move to 'get code', when I push get code button, it doesn't work any thing. just internet disconnected for a while.

URL : https://www.codecademy.com/en/courses/learn-sass/lessons/sustainable-scss/exercises/partials?action=resume22

I sow the other guys have the same problem in Aug 2016.
The code academy didn't solve this problem? :frowning:

I really want to finish this course.
please help me.


#2

Have you tried another browser?


#3

I have the same thing (almost the same, my error is:
expected div.banner to have its border-top style equal to 4px solid black but got 0px none #000000

I'm using the same code as stated above and when it offered me help I tried to click it and it loged off codecadamy (could not connect). I tried chrome, edge and firefox, the same in all of them. Help please?!


#4

Yes I tried using safari. but didn't work at that time.


#5

Same, and I waited for a week, the bug still occurs


#6

Me too. This is the 11th days 8naeum found the problem but still not fixed. I am disappointed.


#7

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.