I'm stuck in "Intro to Environment" even though I've done everything all right

I haven’t made any mistakes, but still I can’t move to the next lesson. I followed everything step by step. Nano works fine, saved everything, cat shows the correct sentence. Nothing I do makes the 2nd instruction go green.
I have tried switching browsers, restarting the terminal, creating other hello.txt even in the other folders. Nothing works.

If you could share some suggestions, I would be grateful.

Link to “Intro to Environment”

The lesson worked for me. Try to reset the lesson and complete the instructions again. Do not clear the terminal. It should look something like this when you’re done…

$ nano hello.txt
$ cat hello.txt
"Hello, I am nano."
$ 

Figured to give it a try and it’s broken for me as well.

Let me go back and Reset and see if this can be reproduced in Firefox/Windows.


Able to confirm that there is a definite problem with this exercise.

Thank you for checking it out. Could you all report this bug as well? Maybe someone will “hear” us :grinning:

1 Like

hi all! I brought this up with the team and they implemented a fix for the lesson while taking a look at everything else to make sure this issue isn’t affecting other lessons as well.

Thanks for bringing it up @serbanscorteanu79234

The <cd I> exercise seems to suffer from a similar issue.

Thank you for fixing the bug!