I'm following this Python video but can't run pipenv --three

Hi guys,

I’m learning Python and following this youtube video to learn about pipenv

but for some reason I can’t use pipenv --three in my VSCODE as it always shows Error: No such option

Anyone can help?

1 Like

I’m having the same problem. This just worked for me:
pipenv --python 3

11 Likes

I just visited Basic Usage of Pipenv — pipenv 2020.6.2.dev0 documentation

it seems like the command is now
pipenv install --three

5 Likes

There is no version “three” of Python.

Which is noted by the error message, Error: No such option

When creating an environment, you can choose what version of Python3 you want to install–3.7, 3.10, etc. etc. (whatever version based on your needs for different projects).

https://pipenv.pypa.io/en/latest/installation/#make-sure-you-have-python

I ran into the same problem, which is curious because the same command worked for the tutor in the video.
Use pipenv python (python version) e.g
pipenv python 3.11 and voila!

pipenv install -three works

they should probably not that somewhere.

I’ve not used pipenv myself, but reading their documentation here, you get a list of valid commands to use with it. --three is not listed anywhere as a valid command, nor is --install three. You need to specify a version of Python to use for your environment.

Very likely the reason that video shows the command pipenv --three working is because the video maker set up an alias for himself to simplify using pipenv, which makes sense if he uses it alot. I would strongly encourage you to just translate that command into pipenv --python 3.11 and replace the “3.11” with whichever Python version you are trying to use (Py 3.11.4 is the current version at the time of this answer).

Alternatively, there are also plenty of other good environment managers including Poetry and venv which comes built-in with your Python installation. Once you get the basic concepts down, look at these and see which one feels the best for you.

3 Likes

Thank you, this was a huge help.

1 Like

Thank you! So glad to find this answer. In VS Code Terminal, I tried:
pipenv --three
pipenv --3
pipenv --3.11

Only “pipenv --python 3” worked for me.

1 Like