I don't think it is.. not sure, has been ages since i done the ruby course on codecademy.
Now, user_input is just a variable, but i like logic names for variables (good programming habit) and well, user_input is a good name for variable to store input from the user.
.is_a? is a build in ruby function, you can use it to check data type (string, integer, Boolean, and so on) it is: is_a? Integer would translate to pseudo code in: is a integer? or is a string? it is almost a english question, in code form, how nice
By default, the user input is a string in ruby:
print "What's your first name?"
first_name = gets.chomp
print first_name.is_a? String
So there is no need to cast it to a string (since it already is a string)