I just can't input ~ (stuck at 79%)


#1

Hello, I am stuck in the third question of 79%... (.bash_profile exercises)

Notice that I am using Linux Mint and for some reason I cannot type nor paste ~
into the codeacademy console command (even using virtual keyboard I
can''t type it)...

However I managed to bypass the previous exercises using the absolute directory: /home/ccuser/

Well... I did all the 4 instructions but the 3rd instruction never goes green.

  1. Open ~/.bash_profile in nano ---> nano /home/ccuser/.bash_profile (step 1 goes green)

  2. Insert: alias pd="pwd" in the file, save, exit and clear console (step 2 goes green)

  3. source ~/.bash_profile --> source /home/ccuser/.bash_profile (step 3 WON'T go green)

  4. try pd command ... and it works! it does the same as pwd command, besides step 3 and 4 not having a green....)

I don't know what else to try:
I tried to make it work using the absolute pathway, or changing to the current directory: cd /home/ccuser/

I am still stuck on step 3 besides having fully understand the exercise -_-


#2

Hey methodbaster13758,

I got through this exercise with the following:
Step 1: type (w/o the " " 's): nano ~/.bash_profile

Step 2: In nano, type: alias pd="pwd"
2A: Hit 'Control - O' (the letter)
2B: Hit 'Enter'
2C: Hit 'Control - X'
2D Type in 'clear'

Step 3: Type in 'source ~/.bash_profile

Step 4: Type 'pd'

It looks like you are adding un-ncessary stuff in step 3 (and 1 for that matter); I didn't use the' /home/ccuser' command but I think you are unable to use that due to your Linux Mint. Seems odd you can't use the tilde (~) button. If that's the case, I don't think the steps above will help because that's beyond me! Sorry.

That should get you through this exercise. NOTE: You will need to remember the 'Control - X' and 'Control - O' to get through the next few steps. I'm still on 5. Aliases II at 83%, so look for my new thread for help on that if you get past it, thanks and I hope that helps.


#3

Hey man!
Thanks for trying to help =) I really appreciate it.

I'll try later on a Windows of a friend (which is an irony, because this course is about command line, in other words, linux).

Hope I won't get more bugs from now on, because I'm damn sure this is a bug.

Just a note, that ~/somefile is the same thing as /home/{user}/somefile

If you enter cd ~ (a command which I believe you already learned, you'll change to the home directory) and then if you enter the pwd command, you will see that the user home is /home/ccuser/

I'll move on, on a Windows PC and then I'll try to help you, once I pass that exercise.

Thanks mate


#4

Hey, I just wanted to point out two things:

  1. I use Linux too, and didn't have any trouble with the course. As long as you're following instructions correctly, I don't think the OS will make a difference
  2. The Command Line course is covering the Unix command line, and covers Unix commands. Linux and Apple are both based off of Unix, and so share a lot of the same commands, but the course isn't built for either of those OSes specifically.

#5

So I should try to install other browser (I'm using firefox)?

The only thing that keeps me from mimicking the exact commands is the impossibility of typing nor pasting the ~ on the command line.

  1. Never could type ~ on the command line of codeacademy, I have been using the absolute directory (/home/ccuser) but now is not working anymore (I guess they expect exactly the ~ to aval the exercise)
  2. The virtual keyboard also does not work.
  3. I can't paste the character.
  4. The ALT+126 (ASCII code for ~) also does not work.

I'm out of ideas. :confused:

What OS and browser are you using?


#6

I was also using Firefox, but switching browsers would be a good idea.

That's really weird. Normally using the ASCII code works for people. What keyboard layout are you using? Switching temporarily if you're using anything other than QWERTY might also solve your problem.

EDIT:

Oh and I missed the last part of your post :)
I'm using Firefox Developer Edition 43.0a2 (I think) on Peppermint 6, with a Dvorak keyboard.


#7

It's a QWERTY keyboard,
I just installed the chromium browser and finally I can insert the ~ char. :smiley:

It still bugs me why I can't do it on firefox, but what the hell... It's a bug and it's not my fault.

Thanks for the comment zystvan.
And mtharris22, I'll get to the 83% in no time, and will help you with exercise 5. (83%) :wink:


#8

Hey man, I just got to 86%. where exactly are you stuck at?

Does your ~/.bash_profile contains:

alias pd="pwd"
alias hy="history"
alias ll="ls -la"
export USER="marco"

PS: "marco" is my name, you can write whatever you want there.

after writing this on the file, save and exit.

Then: source ~/.bash_profile

and finally type: echo $USER


#9

Sadly, the command line on code academy doesn't recognize the virtual keyboards way of writing ~. The solution for your problem is to use the keys ALT-N to get ~ in the command line for code academy (it worked for me at least).


#10

Hi,

For some reason I cannot get past step 2. I'm able to open up ~/.bash_profile in nano. I'm typing

alias pd= "pwd"
hitting Control + O
hitting ENTER
screen says "wrote 6 lines of code"
hit Control + X
typed CLEAR and pressed ENTER

and step 2 is never showing as completed.

Anyone know what I'm doing wrong?


#11

remove the space between the pd= and "pwd" and make ABSOLUTELY sure that there is nothing more into the file...

better... remove the .bash_profile before editting it in nano, just to make sure :wink:


#12

i think I'm dyslexic between 12-3am :smile:

Thanks for pointing out my rather obvious error.

Cheers!


#13

Methodblaster103758,
Thanks for the reply. I finished the exercise. It was pretty smooth sailing after that hiccup. Glad to hear you figured it out with the '~' !


#14

Any one yousing a danish keyboard shift it to english then ~ is on the button where ½ is on and "" is on ø and / on -_ and _- on +?


#15

For you who have trouble getting the ' ~ ' symbol working on the codeacademy terminal,
try ALTGR+numpad3.

Atleast thats how I got it working


#16

Hello,

I cant get past Step 2.

First i used commandline:

$ nano ~/.bash_profile
(this gets me through step 1 and turns green)

It gives me this output then:

$ nano ~/.bash_profile
echo "Welcome, Jane Doe Nano"

For step 2 i then type alias pd="pwd" command below it so:

$ nano ~/.bash_profile
echo "Welcome, Jane Doe Nano"
alias pd="pwd"

Ctrl+O
Enter
this returns message: [wrote 3 lines]
Ctrl+X
clear

Step 2 doesn't turn green now...

Anyone knows what I'm doing wrong?


#17

I'm having this exact same problem, mr_paull. Anyone have any ideas?


#19

I get the answer
You need to save it first.
1.Which is "control+O"
2.and then press "Enter"
3.And then "control+x" (exit nano)
then the second step turns green :smile:

Good luck!


#20

Hey Jay_Chill!

I dont know whats wrong..... it worked for me


#21

Man, this is weird.
It wasn't working for me in Chrome...changed to Firefox and it's finally working...