I have a problem with setting the text-decoration to none

<PLEASE USE THIS TEMPLATE TO HELP YOU CREATE A GREAT POST!>

<Below this line, add a link to the EXACT exercise that you are stuck at.>
I am stuck with the text-decoration: none; when adding a link to the button.

<Below this line, in what way does your code behave incorrectly? Include ALL error messages.>
I get the error message Oops try again, did you forget to set your link’s text-decoration to none;?

```

img {
display: block;
height: 100px;
width: 300px;
margin: auto;
}

p {
text-align: center;
font-family: Garamond, serif;
font-size: 18px;
}

div {
height: 50px;
width: 120px;
border-color: #6495ed;
background-color: #bcd2ee;
border-style: solid;
border-width: 2px;
border-radius: 5px;
margin: auto;
text-align: center;
}

a {
text-decoration: none;
color: #f8f8ff;
font-family: cursive;
}

<do not remove the three backticks above>

Can you please post your html code here?

read this-

I have done exactly what it told me to do in the exercise (except added the strong tags). It is the css that is showing the error. I had this same error on the previous exercise too and couldn’t move passed it so skipped to the adding button. I cannot see where I have gone wrong with my css code (posted in inital post).

Below is my html code but I don’t think the error is in there.

<html>
	<head>
		<link type="text/css" rel="stylesheet" href="stylesheet.css"/>
		<title>About Me</title>
	</head>
	<body>
		<img src="https://s3.amazonaws.com/codecademy-blog/assets/46838757.png"/>
		<p>We're Codecademy! We're here to help you learn to code.</p><br/><br/>
		<div>
			<a href="https://facebook.com">Friend us on <strong><em>Facebook</em></strong></a>
		</div>
	</body>
</html>```

with regard to my CSS code, all the elements are working correctly on the results page including the removal of the text decoration. It’s just that when I click on the save & submit code I get the error and it won’t let me move onto the next lesson. I have tried removing the space as in text-decoration:none; and leaving the space in as in text-decoration: none; and it still doesn’t work.

I have just changed my browser from chrome to firefox and it works. It would suggest to me that there is a bug when using chrome. I have read other posts where people have had the same problem and a swap from chrome to firefox has worked.

2 Likes

Hi guys! I had this problem second time during this project. I tried different browsers mozila, Explorer sometimes it helped or I tried wrote this:
a href= “https://www.youtube.com” style=“text-decoration:none”>Youtube Klick here

Maybe it also help you
Have a nice day.
I hope they will solve this bug because it’s irritating. Besides that I really enjoy this webpage it’s really awsome keep going. BB

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.