I can't see my broadway app after starting a Rails server


#1

I mapped the request for the url /pages/home to Pages controller's home action using the command

get '/pages/home' => 'pages#home'

I then started a Rails server but I cannot see my app in the browser. Any help would be appreciated.

Best,
Iavor


#2

Same error here, I mapped get 'welcome' => 'pages#home'


#3

Ah found out my mistake, I had to map "/pages/home" so my code now looks like:
get '/pages/home' => 'pages#home'
in routes.rb.

It shows a 'not found' message, but at least I don't get a GET error anymore :stuck_out_tongue:


#4

Yeah, I also get a "not found" message. Let me know if you figure it out. I might reset the project and try again.


#5

what's server address are you trying to access?

and is the server running?


#6

Hey savina10,

I first type:

rails s -p 8080

then I attempt to visit:

http://localhost:8080/pages/home

However, the following message pops up:

Not found

#7

There's something wrong. I just get generic help output when I type in rails s -p 8080

Also have the

not found

message in the browser window now. Can't continue at this point.

Just tried to the bolt-network project and same thing.

not found

in the browser window and can't start the server.


#8

you have to be a bit more specific brettr2 sorry. You need the server running when previewing in your browser. :smile:


#9

hmm. I'm not sure but sounds you have a routing error. I would go through steps again and double check you've done everything correct.

pages_controller.rb ok?
routes.rb ok?


#10

@savina10, I can't get the server started. When I type in rails s -p 8080, I get the output in the attached file.


#11

@brettr2 it's because you're not in the broadway folder when you run the command. Type "ls" on the command line and you'll see the folder broadway. cd into broadway and run "rails s -p 8080" from there.

You always have to run the server from inside the folder where it's located if you don't specify "from where" you want the terminal to start a server.

Hope that helps.


#12

When I type "ls", I see bolt-network. I cd into bolt-network. ls shows app. I run the server again but no change. I still get the same generic output. Any idea what is wrong?


#13

is it only showing app folder?

it should be showing:
$ ls
Gemfile app db test
Gemfile.lock bin lib tmp
README.rdoc config log vendor
Rakefile config.ru public

I'm not sure why it's not working. The WEBrick web server is included in rails so should be possible to start server when in Bolt-network folder. Sometimes you need to run "bundle install" too before the server command.

I suggest you restart the course and see if it works straight after you create the Bolt-network app and run bundle install.


#14

this worked for me. thanks!