I can't progress beyond "nano hello.txt"


#1

After opening the nano terminal, I type in Ctrl O, Ctrl + O, but nothing happens after pressing enter. Somebody please help?


#2

Type or use the key combination? Got a screenshot so that we can make our own observations?

Pressing enter in nano should create a new line, or if you're entering a file-name for saving or opening, then pressing enter would tell nano that you're done typing.

Nano gives you feedback with messages near the bottom of the screen, right above the list of commands, perhaps it's saying something that you are not noticing.

There are also other editors/ways of editing text, if things really aren't working for you with nano. But it's probably a good idea to figure out what's going wrong.


#3

Your supposed to use the control button on your keyboard along with o.


#5

thanks a lot for your reply.
I have gotten past my problem, finally. Well, don't I feel stupid.
I just needed to press the "Ctrl" + "O" & "Ctrl" + "X" keys combinations without having to type them into the nano terminal.


#6

Okay, so what happens when you do?


#7

Thanks for your reply. I used the keys combinations and walah! it worked!
I've felt so stupid though, It was there all along.


#8

am on to the next...


#9

I'm guessing that if it was unable to do something, or required information from you, then it would be telling you so, like here:


#10

this is what I was initially doing:disappointed:


#11

Did you make sure to hit return aka enter after pressing Ctrl + O?


#12

I think they meant that their file content wasn't what it should have been


#13

Oh, ok. Well, I don't have any ideas of why it isn't working then.


#14

yeah, I did that.
I have progressed past it now.


#15

Did you make sure to type upper case oh and not zero?


#16

hahaa, sure. it's all good.


#17

Did that fix it, or are you still having trouble?


#18

I fixed it, thanks man.


#19

No problem :slight_smile: I'm always glad to help.


#20

2 posts were split to a new topic: I use mac and command +O opens up the files in computer


#21