Https://www.codecademy.com/paths/learn-how-to-build-websites/tracks/build-websites-on-your-own-computer/modules/local-website-development/articles/visual-studio-code

I have done everything in the video as described. When I copy my path it is not the same as Brendans, in relation to the C: and the back slashes. And when I copy my url into the new wep page nothing shows up like his does. What am I doing wrong? I have removed the folders, created new folders and tried different paths and I cant get my h1 text to show up in the web page. I am using Visual Studio Code.
At the 10min and 15sec mark of the video he copies his path into the web page and his works.

/Users/brendan/Codecademy/hello_html/index.html

C:\Users\AceRoque\Codecademy\hello_html\index.html

Just want to confirm a few things for details, and another user can help…

What exactly are you typing in to the url? Is it C:\Users\AceRoque\Codecademy\hello_html\index.html

Is that the location where you have your file saved? (it may seem obvious, but it’s super important to double-check, I get this wrong if I haven’t had enough coffee -_-)

I copied that from Visual Studio Code. I created the index.html file in Visual Studio, then I right click on that file and it gives me the path and I copy and paste the path. I didnt “type” anything, copy and paste just like the guy in the video tutorial.

‘Users’ is on the root of the C drive so that path syntax should work in a browser. When working on your local machine, try to use relative addressing as much as possible, and work with the HTTP format above. Avoid using DOS path name format.

C:\Users\AceRoque\Codecademy\hello_html\index.html
This path produces nothing when copied into a web browser.

hello_html\index.html This is my relative path. What do I ad to the relative to make it work in a browser?

I do all of the same steps exactly as brendan does in the video. Why do I get back slash when he gets fwd slash? His path produces output into the browser, mine does not. I am confused. Thx

Ok. Let’s see…

This is because you are using a Windows computer, whereas Brendan is using a Mac. Mac OS, like all other Unix-like operating systems, use forward-slashes in their folder paths. Windows is the odd-one-out, in that it uses a backward-slash.

I presume that this means you are right-clicking your index.html file, and choosing the “Copy Path” option from the context menu. This is, I’m guessing, where the C:\Users\AceRoque\Codecademy\hello_html\index.html path has come from?

In which case, since that looks like it should be a valid path, can I check the following:

  1. Have you saved the updated index.html file since adding HTML markup to it? Visual Studio Code does not auto-save by default (you can configure it to automatically save after any changes, if you want) and in the video Brendan may not explicitly say to save. Please check this, as otherwise your index.html file will exist - because VSCode created it - but it will be blank, and would explain your issue.

  2. If you have correctly saved the file, please can you tell us which browser you’re using and provide screenshots of the VSCode window and the browser with the blank page.

Thanks. :slight_smile:

1 Like

I turned on “auto save”. that is why it was not working. I saved it and now I have output on the web page, awesome. And I have never used a MAC, so had no clue about that. I’m glad that worked, been stressing for a day because I couldn’t continue to learn this.
Thank you very much pitycoder, good tips. And thank you to mtf. I feel better now.

2 Likes