Http://localhost:8080/pages/home - not found


#1

After restarting server and going to http://localhost:8080/pages/home, result is "not found".

routes.rb contains this:

get 'pages/home' => 'pages#home'

pages_controller.rb contains this:

def home
end

Server results:

Started GET "/pages/home" for 63.231.136.101 a
t 2016-05-11 00:34:14 -0400
Processing by PagesController#home as HTML
Rendered pages/home.html.erb within layouts/
application (1.5ms)
Completed 200 OK in 153ms (Views: 140.1ms | Ac
tiveRecord: 0.0ms)

What up?


#2

Hi Collin,

Could you try refreshing the entire page? It sure sounds like it should be working to me :confused:


#3

I've refreshed multiple times (last night and just now) and no joy.

Related?: I had been getting 502 Bad Gateway error before the "not found". Took a couple of refreshes after not finding anything wrong with the code before that went away. Now stuck with "not found"

Note: When I just refreshed and started the server, got a message that rake 11.1.2 was not found and I needed to run bundle install again. So, something is wonky as rake had already been installed.

Not sure what to make of all that.


#5

Thought I should add this to the mix of things that may or may not be issue:

When starting the server I'm getting the following:

$ rails s -p 8080
Warning: You're using Rubygems 2.0.14.1 with S
pring. Upgrade to at least Rubygems 2.1.0 and
run gem pristine --all for better startup pe
rformance.
=> Booting WEBrick
=> Rails 4.1.1 application starting in develop
ment on http://0.0.0.0:8080
=> Run rails server -h for more startup opti
ons
=> Notice: server is listening on all interfac
es (0.0.0.0). Consider using 127.0.0.1 (--bind
ing option)
=> Ctrl-C to shutdown server
[2016-05-11 23:34:19] INFO WEBrick 1.3.1
[2016-05-11 23:34:19] INFO ruby 2.0.0 (2015-1
2-16) [x86_64-linux-gnu]
[2016-05-11 23:34:19] INFO WEBrick::HTTPServe
r#start: pid=1112 port=8080

Could this be an issue?:

Warning: You're using Rubygems 2.0.14.1 with S
pring. Upgrade to at least Rubygems 2.1.0 and
run gem pristine --all for better startup pe
rformance.


#6

@netrockstar90294 It could be an issue, do you want to try upgrading Rubygems?


#7

I hit up support. They said that port 8080 isn't working. So use, localhost:8000/pages/home

Also, they said that the Rubygems issue doesn't matter.


#8

@netrockstar90294 Did changing the port you used fix the issue?


#9

Yes it did.

And, thanx :slight_smile:


#10

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.