How to make changes to a website using GitHub?


#1

Hello everyone,

after having finished the “Deploy a Website” exercise, I wanted to know how and where I could edit the files that make up my website in order to change my website ( which is https://adaxasd.github.io/ ). I edited and committed the files in my GitHub repository, however my website still hasn’t changed. How do I make the changes of the files in my repository appear on my actual website?

Help is wanted,
thanks.


#2

after you added and committed the files you need to push them to github:

git push origin master

assuming your remote is origin which you can verify with:

git remote -v

#3

I tried typing those commands into my PC’s command line and it didn’t work, where do I need to enter the command?
Could it be that I need to get Bash on Windows in order for the commands to work?


#4

git is a piece of software you need install, for windows there is git bash:

https://git-for-windows.github.io/

You could indeed install bash first as well, and then install git in bash

personally, for web development and the use of git i would use Linux altogether but then this is my personal opinion.


#5

Ok, thanks a lot! :smiley:


#6

Okay, I tried typing
$ git push origin master
into GitBash, but it only returns this error message


$ git push origin master
error: src refspec master does not match any.
error: failed to push some refs to ‘https://github.com/adaxasd/adaxasd.github.io


#7

i found a stackoverflow question:

did you commit anything before pushing to remote repository?


#8

Oh, no I haven’t yet. But now I think I understand what I need to do.
First I need to download the files that are in my GitHub repository,
then I can edit them and then I can commit and push them to GitHub.


#9

yes, you first need to create a repository on your pc:

git init

then set the remote:

git remote add origin https://github.com/adaxasd/adaxasd.github.io.git

then you can pull everything:

git pull origin master

#10

Ok, that was successful, with what program can I edit my files now?


#11

anything that can be used to edit files you have, this can be any text-editor (atom, brackets, sublime text)

git is only version control and collaboration tool


#12

Ok, now I edited two files, added them, committed them and pushed them, but my website still hasn’t changed.


$ git commit -m “Save my work”
[master 17de61c] Save my work
2 files changed, 2 insertions(+), 2 deletions(-)

$ git push origin master
Counting objects: 6, done.
Delta compression using up to 4 threads.
Compressing objects: 100% (5/5), done.
Writing objects: 100% (6/6), 549 bytes | 549.00 KiB/s, done.
Total 6 (delta 3), reused 0 (delta 0)
remote: Resolving deltas: 100% (3/3), completed with 3 local objects.
To https://github.com/adaxasd/adaxasd.github.io
f8354f2…17de61c master -> master

Is there something else I need to do in order for my website to change? ( I changed the base font family to $base-font-family: Georgia, “Times New Roman”, serif; )


#13

no, all should be good now. But this is where my knowledge ends

SASS is certainly not within the things i know

the git commit got through, so that is good


#14

Hm, I just noticed that GitHub is sending me this e-mail:
The page build failed for the master branch with the following error:

You have an error on line 12 of your _config.yml file.

And this is what my _config.yml looks like


1 # Welcome to Jekyll!
2 #
3 # This config file is meant for settings that affect your whole blog, values
4 # which you are expected to set up once and rarely need to edit after that.
5 # For technical reasons, this file is NOT reloaded automatically when you use
6 # ‘jekyll serve’. If you change this file, please restart the server process.
7
8 # Site settings
9 title: ADAXASD
10 email: your-email@domain.com
11 description: > # this means to ignore newlines until "baseurl:"
12 Write an awesome description for your new site here. You can edit this
13 line in _config.yml. It will appear in your document head meta (for
14 Google search results) and in your feed.xml site description.
15 baseurl: “” # the subpath of your site, e.g. /blog
16 url: “http://yourdomain.com” # the base hostname & protocol for your site
17 twitter_username: jekyllrb
18 github_username: jekyll
19
20 # Build settings
21 markdown: kramdown

Can you find an error here?


#15

i don’t know Jekyll either, i completed this course, but then decided this is not the path i wanted to walk

I helped you with the original questions you had because i understood those, finding the error in the config file you will need to find on your own (google, our friend) or create a new forum topic


#16

Ok, thanks, I’ll try on my own to fix the problem.
EDIT: Found it, two spaces were missing in front of lines 12, 13, and 14. If you look at my site now, I can edit it. ( https://adaxasd.github.io/ )


#17

Finally achieved with proper way or not ?? and try resolve it so that it would be helpful for some one looking after it with ReactJS mentoring…


#18

well, there seems to be new commits and change, so it appears to be working


#19

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.