How to fix warnings and errors installing pipenv Windows 10

I have tried to install pipenv and recieved the following warnings and errors on Windows 10. How do I fix this and install pipenv?

Exercise: installing pipenv on MacOS and Windows.  https://www.codecademy.com/courses/learn-python-3/articles/learn-python-pipenv

C:\Users\Friends>pip install --user pipenv WARNING: Ignoring invalid distribution -ip (c:\python39\lib\site-packages) WARNING: Ignoring invalid distribution - (c:\python39\lib\site-packages) WARNING: Ignoring invalid distribution -ip (c:\python39\lib\site-packages) WARNING: Ignoring invalid distribution - (c:\python39\lib\site-packages) Requirement already satisfied: pipenv in c:\users\friends\appdata\roaming\python\python39\site-packages (2021.11.23) Requirement already satisfied: pip>=18.0 in c:\python39\lib\site-packages (from pipenv) (21.2.3) Requirement already satisfied: virtualenv in c:\users\friends\appdata\roaming\python\python39\site-packages (from pipenv) (20.10.0) Requirement already satisfied: virtualenv-clone>=0.2.5 in c:\users\friends\appdata\roaming\python\python39\site-packages (from pipenv) (0.5.7) Requirement already satisfied: setuptools>=36.2.1 in c:\python39\lib\site-packages (from pipenv) (57.4.0) Requirement already satisfied: certifi in c:\users\friends\appdata\roaming\python\python39\site-packages (from pipenv) (2021.10.8) Requirement already satisfied: six<2,>=1.9.0 in c:\python39\lib\site-packages (from virtualenv->pipenv) (1.16.0) Requirement already satisfied: distlib<1,>=0.3.1 in c:\users\friends\appdata\roaming\python\python39\site-packages (from virtualenv->pipenv) (0.3.4) Requirement already satisfied: backports.entry-points-selectable>=1.0.4 in c:\users\friends\appdata\roaming\python\python39\site-packages (from virtualenv->pipenv) (1.1.1) Requirement already satisfied: filelock<4,>=3.2 in c:\users\friends\appdata\roaming\python\python39\site-packages (from virtualenv->pipenv) (3.4.0) Requirement already satisfied: platformdirs<3,>=2 in c:\users\friends\appdata\roaming\python\python39\site-packages (from virtualenv->pipenv) (2.4.0) WARNING: Ignoring invalid distribution -ip (c:\python39\lib\site-packages) WARNING: Ignoring invalid distribution - (c:\python39\lib\site-packages) WARNING: Ignoring invalid distribution -ip (c:\python39\lib\site-packages) WARNING: Ignoring invalid distribution - (c:\python39\lib\site-packages) WARNING: Ignoring invalid distribution -ip (c:\python39\lib\site-packages) WARNING: Ignoring invalid distribution - (c:\python39\lib\site-packages) WARNING: Ignoring invalid distribution -ip (c:\python39\lib\site-packages) WARNING: Ignoring invalid distribution - (c:\python39\lib\site-packages) WARNING: You are using pip version 21.2.3; however, version 21.3.1 is available. You should consider upgrading via the ‘C:\Python39\python.exe -m pip install --upgrade pip’ command.

C:\Users\Friends>C:\Python39\python.exe -m pip install --upgrade pip’ WARNING: Ignoring invalid distribution -ip (c:\python39\lib\site-packages) WARNING: Ignoring invalid distribution - (c:\python39\lib\site-packages) ERROR: Invalid requirement: “pip’” WARNING: Ignoring invalid distribution -ip (c:\python39\lib\site-packages) WARNING: Ignoring invalid distribution - (c:\python39\lib\site-packages) WARNING: Ignoring invalid distribution -ip (c:\python39\lib\site-packages) WARNING: Ignoring invalid distribution - (c:\python39\lib\site-packages) WARNING: Ignoring invalid distribution -ip (c:\python39\lib\site-packages) WARNING: Ignoring invalid distribution - (c:\python39\lib\site-packages) WARNING: You are using pip version 21.2.3; however, version 21.3.1 is available. You should consider upgrading via the ‘C:\Python39\python.exe -m pip install --upgrade pip’ command.

C:\Users\Friends>pip install --upgrade pip’ WARNING: Ignoring invalid distribution -ip (c:\python39\lib\site-packages) WARNING: Ignoring invalid distribution - (c:\python39\lib\site-packages) ERROR: Invalid requirement: “pip’” WARNING: Ignoring invalid distribution -ip (c:\python39\lib\site-packages) WARNING: Ignoring invalid distribution - (c:\python39\lib\site-packages) WARNING: Ignoring invalid distribution -ip (c:\python39\lib\site-packages) WARNING: Ignoring invalid distribution - (c:\python39\lib\site-packages) WARNING: Ignoring invalid distribution -ip (c:\python39\lib\site-packages) WARNING: Ignoring invalid distribution - (c:\python39\lib\site-packages) WARNING: You are using pip version 21.2.3; however, version 21.3.1 is available. You should consider upgrading via the ‘C:\Python39\python.exe -m pip install --upgrade pip’ command.

C:\Users\Friends>pip --version pip 21.2.3 from C:\Python39\lib\site-packages\pip (python 3.9)

You should try getting a package manager like Chocolatey, then you could just
$ choco install python3
$ choco install python3-venv

Good luck!