How can a website teaching coding possibly have so technical glitches?

I have been trying to learn python and have had my progress blocked several times because the ■■■■ script won’t load and so the entire exercise crashes. Unbelievably frustrating.

When trying to reset the workspace, I’ll get a message like:

Whoa there!

4/ has been moved. This will cause problems with this exercise, please move 4/ back to its original location, or reset your files

Then when I try to reset the files, instead of the workspace going back to the default code that started on the page, the entire script will go blank and all progress in the course comes to a grinding halt!

What the actual ■■■■?

I get that this is a free service, maybe the issue is lack of server space for non-paying users or something…but it’s incredibly frustrating.

I have tried refreshing the page, closing and reopening my browser, even restarting my comp. I have tried starting the entire exercise from scratch and still run into the same problem at the same place in the exercise. This has happened in multiple exercises too - it is not an isolated issue. Are others running into similar issues in courses other than Python?