Hi! i have a problem setting up git in my computer, i followed matt on the video, i typed the same thing as him but the result isn't the same on my console i think there is an issue


if you take a look at the video via the link, it’s on the 4.10 mnt…

Hi @wilfriedpiwo35277140,

Make sure you put quotes around any file names that have spaces in them. Otherwise Bash will think it is another command. Try cd c:/"code learning"/mycde

hi ! thank for your response. i will do like that. but why it works without quotes for matt ?

Because his folder names had no spaces in them.

1 Like

thank u man :slightly_smiling_face:

hi guy please take a look, i have another issue , i created the README.txt file as him , and type the same thing but my console don’t show the same result. if you take a look at the 4:57 mnt when he typed ( git init) a file named .git appear in his codecademy folder, but that’s not my case. i think it’s the reason the gir server tell me that ‘README.text’ did not match any files.

It looks like you did not make a README.txt file in the same folder as your repository before trying to add it using git. However, because your screenshot only shows your Git Bash and not your folder, I can’t say for sure. If you follow the steps from the video exactly, you won’t have any problems.

1 Like

@wilfriedpiwo35277140, please make sure you mark my answer as the solution if it fixed your problem. Thanks!

sure man already! please have a look at my screen you can see my repository path, may be it can help you understand what is wrong. notice that i followed exactly his recommandation. but what really wonder me is that after typed ( git init) the sever shows the same result as him but in my repository the ( .git) is not created , that is the point.

In your other screenshot, your Git bash said “Initialized empty Git repository”, so it should be there. On Windows, I believe the .git files are usually hidden. Go to View (Affichage) and select the checkbox that for “Hidden Items.” I’m not sure what that will be in French on the computer.

Once you put a check mark in that box, you should see the .git file. However, the reason you couldn’t add README.txt to your git_practice folder is because you never made the text document. On the video, he shows that you can right click in the file explorer and just select New > Text Document. You cannot add anything in git that you haven’t created yet…

thank you so much for your assistance man, it appeared. yeah i made the text doc as him the other time, this time, i stopped after get init because i didn’t see the doc appear.

i will need your help again man. i want to add README.txt but the server say that it "did not match any files as you can see in the console.

make sure your README.txt file is in the git_practice file and not the .git file…

yeah it’s have a look at my last images .

hm…that’s strange. It’s hard to tell from here, but this is what I would do:

  • Double check that your path is correct
  • Double check that your README.txt file is saved
  • type ls and hit Enter in your Git Bash. if README.txt shows up in the output, then it should work.
  • Try git add README.txt again
  • Try git add . (This means add all files)
    If that hasn’t worked, just try deleting your file and making a new one. Good luck.

when i type ls the output is README.txt.txt