Help installing python on pc (windows)

Hi, I’m very new to coding so forgive me if I’m being a bit dense!
I’m trying to follow the instructions provided on https://www.codecademy.com/articles/install-python3 to correctly install python but I’m having some issues that I hope some one can help me with.
I’ve downloaded and installed python 3.8 and miniconda as per the instructions, but I’m stuck with simply checking the version and conda list as suggested by the guide.
When I type python --version into both CMD and powershell, I am not given a response by the terminal. I have run the same command using Bash and get a permission denied response.
I used chmod to get around this in Bash and it did return the response, so I tried to continue using Bash to finish the guide, however when prompted to type conda list, Bash returns bash: conda: command not found.
I tried continuing the guide to test executing my first script as per the guide’s instructions and was able to create and add code to the test file mycode.py, however when I tried to call it in Bash I got another permission denied message.
I googled this and so tried to use the su or sudo commands but get the response bash: su: command not found so now I have no idea what to do.
I tried to install jupyter too and got a massive amount of red text with and error at the bottom ERROR: Command errored out with exit status 1: python setup.py egg_info Check the logs for full command output.
I’m probably missing something obvious but its bothering me that I can’t seem to just check this simple information!
Any help would be greatly appreciated!!

What exactly are you trying to install or do?

Trying to install Python as shown in the Codecademy guide I linked. When prompted to check the version in Command Prompt nothing is returned to the terminal. A friend asked me what happens when I just type python to the terminal, and the Windows App Store takes me to the page for Python 3.7. He suggested that it means that Windows can’t find the install. I reinstalled twice and double checked that I had added it to PATH so don’t know why its not working. I downloaded and installed version 3.8 but it seems like Windows doesn’t seem to recognise that it is there. He told me that he installed this version months ago and does not have this problem himself, so its not like Windows can’t detect it.

Still clear as mud what you’re trying to do.

You’ve installed it, but you’re trying to install it?
If you want to run it from cmd/powershell then yeah it needs to be in a directory listed in $PATH (unless you type out the full path when running it)
Python’s gui installer (python.org) can modify your $PATH for you, there’s a checkbox for that.

I’m just trying to follow all the steps in the guide.
Whenever I tried to just check what version was installed nothing happened, and I had checked the PATH checkbox.
Anyway I’ve just been on Windows app store searched for 3.8 and apparently I didn’t have it installed (I did). So I’ve installed it from there and now it seems to be working.
However I am now having issues installing Jupyter.
I tried installing it as explained in the guide but got this error message following pages of red error text:

You could either use conda for that, or install it with pip. Those are two separate environments though, and don’t have much to do with each other. Whatever you’re referring to as bash would be a third separate environment

Are you running your intended version of python?
python --version
Do you have a functioning installation of pip?
python -m pip --version
Install jupyter
python -m pip install --user jupyter
…and run it
python -m jupyter notebook

I’d use wsl instead though (ubuntu in windows store) because windows doesn’t really do anything for you so you may as well ditch it instead of using a long list of workarounds (which would be bad when you don’t understand the workarounds and also not the thing you’re trying to do)

but then again the above probably does what you’re looking for for the moment.

Thank you I appreciate your help. I have stopped using it in Bash as I think its just making things unnecessarily complicated.
I ran each of the commands you listed and the first two returned appropriate versions. But when I use the jupyter install it just doesn’t seem to like it and returns the same error message after attempting to install it. I’ve been looking online and apparently windows not recognising the manual install from python’s website is a common issue, and that using the AppStore version messes with permissions. When I tried to install jupyter in conda it said that permissions were incorrect.

What exactly does pip say for this?

python -m pip install --user jupyter

(from cmd.exe or powershell, not conda because this is not at all how you would install things there)

I still have no clue what you mean by bash (some form of work-around environment for windows, but there are several, and they’re not bash, that’s not their identity. bash just happens to be one of the things they include)
But if you have python there as well, and that’s likely a separate installation of python from your windows one, then you could run the same command there in attempt to install jupyter

…or do it in conda, but then you’d ask conda (instead of pip) to install it, that’s kind of the whole point of conda as I understand it - to package things for people who don’t know how to use their os (or in other words, every windows user)

By Bash I am referring to GitBash. But it won’t run python as it says permission is denied.
The read out from the command is:






That’s not about permissions, it’s that you’re missing a compiler.

Which brings us back to that’s what conda does, packages things up.

Use conda or wsl

You could also install that compiler, there’s a download link in your error message.

You could also not use jupyter, you’d probably be confused about what exactly is beneficial about it, I am.

I opened the anaconda prompt (assume that’s what you meant) and typed conda install jupyter,
and it returned a list of packages to install and I responded ‘y’ when prompted to continue.
It returned this:


Haha to be honest I don’t even know why I need it yet, just following the guide like a lost sheep!

You’d want it to install it somewhere else, that is not an appropriate location and I’d be a bit surprised if it picked that entirely by default.

No clue, never used it.

Would you recommend a reinstall in that case?

Perhaps re-installing conda under your own user (or anywhere really, could for example put it in your own C:\Programs) would make it pick that location. This would be more appropriate. (under the assumption that its installer asks you for a location)

Or if there’s an option to install the packages under your user. That’s what the --user flag was for for pip

Oh it says ProgramData … I read that as Program … files? Idk what’s what in windows. Maybe that’s a directory you created in which case it’s entirely appropriate. Or maybe not. Your os, not mine.

If it’s a system directory then you shouldn’t be touching it, and getting permission denied isn’t saying “you should do this as admin” it means “hey go do something you have permission for instead”

Well I reinstalled it under my user and I have tried to install jupyter via conda and I didn’t get an error message this time! I also used the run command and it worked! Must have been the wrong folder. Thank you very much for your help and time :smiley:

This topic was automatically closed 18 hours after the last reply. New replies are no longer allowed.