Helo Rails 1


#1

Does not work. I am typing what it says "rails new Mysite" but it won't let me go to the "next" part. what is the problem? am i doinng something wrong?


#2

also i wasnt allowed to put two L's in the word "hel lo" when i wrote the title. it says the word " h e l l " is censored. I hope i didnt traumatise anyone by writing this... eh?


#3

Hi @owen358,

You need to capitalize Site, like this:

$ rails new MySite

i wasnt allowed to put two L's in the word "hel lo" when i wrote the title

That's a known bug with Discourse (our forum software) right now, sorry for the inconvenience! Hopefully it'll be fixed pretty soon :slight_smile:


#4

ah ok, but now i have a different problem. yesterday it wouldnt let me click "next" today i can't even type anything in the terminal. its just all locked. is anyone else having this problem?


#5

@owen358 There's currently an issue affecting some of Codecademy's courses (including this one), the staff knows about it and should have it fixed soon :slight_smile:


#6

@owen358 FYI the course should be back up now.


#7

I just tried again. the first 3 steps work ok but the 4th doesnt. the link says unable to connect. my interenet connection is fine so i dont think the problem is my end.

View the Rails app in the browser by visiting http://localhost:8000.
Then click Next to find out what these commands do.

after i go back i must repeat all 3 previous steps again. I tried 4 times with the same result.


#8

@owen358 If visiting http://localhost:8080 inside the virtual browser doesn't work, could you please post a screenshot and link to the exercise?


#9

https://www.codecademy.com/courses/learn-rails/lessons/start/exercises/start-hello-rails?action=lesson_resume

not sure how to do a screenshot on my computer. il try taking a photo


#10

also what do you mean by "inside the virtual browser"? i am clicking on th elink and its trying to open as any other web page in a different window. is the re a way of opening it within the codecademy web page? maybe im doing something wrong


#11

i see there is a space for pasting URL on the right. i did that but now the "next" button is not highlighted and its telling me to do things. sorry but im new and have no idea what its talking about

i have no idea what any of this means.....

Use rails generate to create your models and controllers

To see all available options, run it without parameters.
Set up a root route to replace this page

You're seeing this page because you're running in development mode and you haven't set a root route yet.

Routes are set up in config/routes.rb.
Configure your database

If you're not using SQLite (the default), edit config/database.yml with your username and password.

#12

@owen358 You can ignore the text in the page, you only have to visit that URL to check that it's working so far. Did you get an error? After viewing the page, you should be able to proceed.

This website shows you how to take a screenshot on most operating systems:


#13

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.