Grep 1. Pt 2 not working,


#1

I have tried many times to get the second part of the first grep exercise working. I typed in the code exactly as it appears in the instructions but it isn't working. Thanks.


#2

Your command is slightly different!


#3

Thanks for replying. I have checked my code and it seems to be exactly what is contained in the instructions. In what way is my code slightly different?


#4

Step up your comparison game!

  • Look harder (I spotted this in seconds, the fonts in your screenshot are designed to be unambiguous)
  • Copy one of them below the other
  • Use Python or some other language to compare the strings, remove half until there's only one differing character left.
  • Convert the text to bytes, compare each byte value
  • Use an online tools for comparing text
  • Or even circumvent the problem of finding the difference and copy-paste from the instructions

#5

Ok thanks for the advice :slightly_smiling:


#6

Hi,did you get it to work? I have the same problem and I don't really understand the other reply because my code is exactly the same as in the instruction and its still not working :confused:


#7

Nevermind I fixed it :smiley:


#8

Glad that you got it to work. My problem was that I typed 'R1' instead of 'Rl'