I fail to see the value of using variable names with no meaning that only serve to confuse the reader, even one’s self. Simple variable names that describe what they are is better all around.
s = sorted(list)
Which brings us around to using reserved words as variable names.
list is a reserved word, a function in global scope. If you were to try to use the list function in the context of your function, it might not work, since locally,
list is not a function. Avoid using reserved words for variable names or you could find yourself looking for bugs that are hard to find.
s = sorted.sample
median is a concept relating to statistics. There are two kinds of statistical collections… Census, and sample. When all the data in a census is collected and used in an analysis, it is called the census data. When only a sampling, or subset of the collection is used, it is called a sample. In terms of median, either term would be reasonable to use as the parameter name since they both describe roughly the same thing… A collection of data points.
In programming, the language we use in our code should speak to the concepts to which they relate, not be some made up term that means nothing to anybody, and may be perhaps a joke to the writer that nobody catches on to since the punch line is in the writer’s head. If you really want to be a programmer, then start by learning how to name variables so they mean what they are supposed to mean. Variables are for human readers, not the computer.
bigger_thurst = len(big_thurst)
n = len(s)
Using meaningless names adds to the verbosity and creates bloat where none is needed. It makes reading almost painful and does not paint a clear picture of the purpose of the function and its expected returns.