GitHub personal access token issue

My GitHub project
/Users/jeanineloughlin/new_projects_codecademy/testing-github-issues

I recently posted in the codecademy forum that I was unable to push my local repository to my remote GitHub repository.
The problem/issue was that as of August 13, 2021 GitHub would no longer accept your password when pushing to
a new repository. Instead a user is required to create and use a 'personal access token".
But my personal access token was not being accepted. And I kept receiving various errors:
A 403
that I was not associated with my GitHub account
Github also said I was using a password still, but I was not, I was using the access token I created
So I created a local repo and a remote repo in Github to try to push to in an attempt to resolve this issue.

It took some patience and time, but I was finally able to use the personal access token and push to GitHub.
So, I wanted to provide my experience fro anyone who might be having the same issue.

2 Likes

Glad to hear you got it sorted. Was there anything in particular that fixed it or was it unclear?

Not entirely sure what the issue was.
As I indicated I created three ‘personal access tokens’.
The first two did not work when I did a ‘git push -u origin main’
I deleted both, and created a third ‘personal access token’
I coped it (as directed by GitHub)
and pasted it when prompted for my ‘password’ (but its a personal access token - jeez GitHub)
and it worked.
I have since created another new local and remote repository successfully.
And I am not being prompted for username/password as Github confirmed my access token.

1 Like