Git merge Part 5 Step 2

Can you think of any reasons why it would might be up to date?
Should your current branch be different from master? If so why, and did that happen? Or maybe the merge has already taken place.

I’m having the same issue.

1 Like

Yeah. Let me scratch my head over that a bit.
That’s definitely not a situation that it should be giving you, it should have created a new commit after you cloned.

It’s misbehaving badly. Closing and re-opening the shell seems to make it reset a few things on its own.

But… yeah, misbehaving in all kinds of ways, I wouldn’t suggest that anyone continue


Im stuck at the exact same part.

Typing: ‘git merge origin/master’ or ‘git merge origin’ or ‘git merge master’ does not do anything and gives the same error as in the printscreen submitted by sandsbe20.


Alright, after some more trial and error… here is how I got past it in the end:

  1. Pressed Get Help in bottom right and clicked restart.
  2. Got to step #2 again and same problem as described in this thread.
  3. Closed the bash terminal by clicking the X
  4. New session
  5. cd my-quizzes
  6. git fetch (yes, again!)
  7. git merge origin/master
  8. (At step #3 type): git log

Hope this helps anyone with some error.


great! this solution works fine. but… why we have to do a fetch again!? it’s a bug of codecademy exercises? anyone reported that? and sorry for my english… i’m from Brazil. =D

Thanks - I followed your steps to bypass this error as well.

Thanks for solution!
I did only steps 3-8 from your solution and it works fine!

1 Like

If anybody likes to know, the origin(:grin:) of the problem resides in the last exercise ( 4.git fetch ).
Here is the screenshot for more information:

And the bug is that the science-quizzes won’t be updated unless we close the bash session and open a new one. (Maybe has do with the inner workings of ccterminal.)

Actually a new directory will be created , changing it from ~/workspace/curriculum/ to ~/workspace/curriculum-a/

So ultimate solution is to close and open the bash session at the beginning of every exercise.


This solved my problem

Nice job gertjandw. Thank you!

Thanks a lot gertjandw!

Thank you! This was the solution to the problem. Basically I had done “git fetch” in a wrong way on the previous step.

Yep, same problem and I have found out why.

I went to science-quizzes directory and see that there is still only two files and biology.txt does not exists!

ssssoooo, i created it by myself, added, commited and BAM! Commands in instruction worked well in my bash, but exercise still not passed =( maybe cuz lines in bash are not the same as in example in instruction.

so i think it is some bug in excercise.

upd: passed by closing bash and starting new session in each excersice.

1 Like

Oh my gosh I was stuck here forever… thank you so much!!!

you are a genius man !!!

This approach works very well.

Thank you barbodgif! I tried various other proposed solutions in this forum to no avail . It was only after I read your post, suggesting that the user close and open a new bash session at the beginning of every exercise, that I was able to continue. So once again, thank you !

If anyone is having this issue, i suggest reading the post made by barbodgif !

1 Like

Thanks for the answer. I was getting frustrated with this step.