Git init not working


#1

can someone help me please


#2

Looks like git init is working just fine - it printed a success message.

The checkpoint on the other hand..

You might be in the wrong directory. You might be supposed to be in ~/workspace/daw/personal-website

...I'll have a look at it brb

Yeah. You moved out of where you're supposed to be, if you look at the commands in your screenshot

Might wanna start over a bit:

cd                        # go to your home dir
rm -rf * ~/workspace      # wipe out the old stuff
mkdir -p ~/workspace/daw  # re-create daw dir
cd ~/workspace/daw        # move into it
jekyll new personal-website  # create the jekyll website again
cd pers*                  # move into it
git init                  # now you're in the right place and can create a repo

kind of overkill but since I can't see the feedback it's easier to just wipe things out


#3

it worked thanks so much for your help


#4

It worked. Thank you! Why codecademy doesn't fix it?


#5

It's not really a bug, an enhancement would be to add a check for where your git repo was created .. I have actually created a bug report on that a few weeks back but I have no clue when or if they would implement it.
Until then, keep in mind that you need to be in the correct location when you run commands that depend on your current working directory. You have to do that when you're in your own environment anyway.


#6

A post was split to a new topic: I got stuck here


#7

A post was split to a new topic: All my code is gone and nothing works


#8

2 posts were split to a new topic: I do not think it is working


#9