Git init not working?


#1


https://www.codecademy.com/courses/deploy-a-website/lessons/github-pages/exercises/git-init?action=lesson_resume&link_content_target=interstitial_lesson

I can't get the git init command to work or be recognised...




Replace this line with your code.


#2

I have tried to put git init into every directory that could possibly be my site's directory.. and nothing.. can anyone please advise?

thanks


#3

I had the same problem. What I did was reset the exercise under the Get Help button and then i typed

cd personal-website

and then I typed

git init

It worked for me afterwards. I am not really sure why, but it did.


#4

I had the same problem, but now I knew the solution. So when running this:

cd personal-website

terminal responds 'no such file or directory', right? So, you have to make a directory with name personal website. To do this you have to run:

mkdir personal-website

Then, if you change directory to personal-website and run git init a repo must be initialized.
Hope, I'd help you!


#5

Thanks! I had the same problem and your solution helped!


#6

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.