Git / GitHub push problem

Hi guys, so i’m struggling really hard when i attempt to push my repository from Git Bash to Github. I’ve already commited my file to the main branch but when i finally get to the command “git push -u origin main” and press Enter nothing happens!!! i don’t get a message error or anything it just seems Git Bash stops from running when it was supposed to ask me for my email and password from github. :slightly_frowning_face: :worried:

3 Likes

Hi @paulap3rre3t, can you post a screenshot of your git log ? It’s weird because if you followed all the steps, everything should work fine.

1 Like

I am having the same issue! if you found a solution please let me know
Best of Luck

1 Like

Hii there i actually found the solution for my problem, do you use windows? i unistalled the git bash from my computer and installed it again, then throughout the process of the installation i marked the one saiyng “use Windows default console window” and it worked for me!!! I hope it does for you too :slight_smile: Lemme know!

2 Likes

It was actually an installation issue i had with git bash, but i solved it now :slight_smile: thank you so much

I do use windows, and I tried your suggestion and it worked. Thank you very much. :slight_smile:

1 Like

I can’t believe it nor I can understand the reasons BUT I typed git push -u origin main into CMD and – it worked like a charm. I think I turned the whole Google upside down looking for answers. Unfortunately, the actual reason why Git Bash isn’t working with such simple commands right now is a total mystery to me.

A few side notes:

  1. it’s not necessary to reinstall Git Bash. Just try CMD instead.
  2. also, I noticed that git remote show origin shows that HEAD branch has a value of (unknown). I suppose, this where the whole thing breaks down. Hope, there’s a super-git-hero who can explain why this happens…

image

1 Like

Thank you so much, it works for me!

1 Like

I’m glad this post helped you! :slight_smile: