Git could not resolve host

Hello, I’m working through this article:

when i get to the

git push -u origin main

bit when trying to push to github i get this error:
fatal: unablee to access ‘’ could not resolve host:

FreakingLoki is my username on GitHub

I tried testing my connection by using


and do get a reply:

Pinging [] with 32 bytes of data:
Reply from bytes=32 time=40ms TTL=243
Reply from bytes=32 time=38ms TTL=243
Reply from bytes=32 time=36ms TTL=243
Reply from bytes=32 time=37ms TTL=243

Ping statistics for
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 36ms, Maximum = 40ms, Average = 37ms

I’m not sure what i could be missing. I’ve poked around on Stack Overflow and here on the Codecademy Forums and none of the suggested fixes seem to work. I’ve tried resetting proxy configs and the like I’m on a personal windows PC not behind a proxy and my firewall is allowing git through. Nothing seems to be working.

Thank you all in advance.

1 Like

Check the config settings. ‘ should be ‘FreakingLoki/git_practice · GitHub
The dot after the com being a slash.

Failing that. Login to github check the repository name matches and the branch names match.

here’s a screenshot of another attempt to follow the instructions laid out on GitHub. I’m not sure why it’s trying to push to instead of /FreakingLoki

I ran

git config --list

and I see


I need to change the “.” after .com to a “/” right? how would I do that?

git remote set origin

More instructions here

I tried to create an account with GitHub, being blocked by Username. Anyone knows why?

I had the same issue and flushing the dns and reseting it helped me. This only happened once with me though and DNS reset is what worked for me. Check it out