Git bash is not working

I got a new computer and downloaded git bash just for my offline project. However, when I went to use it I got this message 15106689 [main] bash 409 dofork: child -1 - CreateProcessW failed for ‘C:\Program Files\Git\usr\bin\bash.exe’, errno 8
bash: fork: Exec format error
I tried redownloading it with and without my antivirus. I also tried making sure everything pertaining to git was deleted and then redownloading it but I forgot to turn off my antivirus that time. Instead I tried using git command and it worked until I had to push my changes and I got this: C:\Users<tookoutname>\excursion>git push origin excursion
error: src refspec excursion does not match any
error: failed to push some refs to ‘https://github.com//excursion.git’
IDK if it’s two different problems or all related to one.

The gitbash error is not I’ve run into before and your best option might be to have a web search for that error code to see if there’s any useful suggestions.

For running git commands and receving the warning about refspec does not match any, the link in the following might be useful-

When I Googled the error but I could not find anything that would help. However, I talked to my brother who makes games. He told me to delete GIT completely from my computer and redownload it. Then make sure all my work was going to a dedicated folder. This has worked so far, however I can not download the gh - version.