Git add <filename.txt>


#1

I'm trying to have git recognize a new file with git add but cant seem to get anywherez
Whaz wrong with this?

git add


#2

Sorry, I did this yesterday and now it won't show my work! Ugh! I will try to re-loop and get past it. If you pass this one, see if you can help me on my other post for the next step (step 6).

If a remember, git add went like this:

'''git add <scene-1.txt>'''


#3

Yes the command should be git add then you can enter the first letters and press tab to autocomplete.


#4

I could not see the output, where Git indicates the changes to be committed with "new file: scene-1.txt" in green text.


#5

Because it doesn't work


#7

When we see something like this in a syntax key,

<file>
<filename>

It means type the file name with no quotes.

git add scene-1.txt

#8

yeah im having the same problem...


#9

I put like "git stage scene-1.txt", and it works, but I really didn't understand so much...
Oh, and the green text saying "new file: scene-1.txt" shows up too...


#10

For now, let's please stay in the confines of the course intro. There is more to come and we only really need to 'git' the current proceedings, without extrapolating beyond. Give that time. It would be inappropriate to discuss anything in this thread that has not come up in the lessons, and git stage has not come up yet.


#11

If you're still stuck on 6, type
git diff
and
q
to exit diff mode


#12

Try this:

git add scene-1.txt

It worked with me.


#13

Hey @wscody, if your question has been answered, take a moment to mark the reply that solved the problem.


#14

don't use the <> brackets I was stuck on this one for a bit too.
Just type:

git add scene-1.txt


#15

Yep. Worked for me too. I got bash: syntax error near unexpected token `newline'. Removing the angle brackets <..> resolved it. Thanks mtf


#16

I type that in and it says its wrong still


#17

Can you copy/paste what you typed so we can have a better look?


#18

git add scene-1.txt i say that and it says wrong


#19

I have same problem...its says thats wrong


#20

Please show us a screenshot so we can see what you see.


#21

just solve it with git add scene-1.txt