Git 5 step 2 "not something we can merge"


#1

Someone! Help!

https://www.codecademy.com/en/courses/learn-git/lessons/git-teamwork/exercises/git-merge-ii?action=lesson_resume&link_content_target=interstitial_lesson

When I say,

git merge orgin/master

it says,

merge: orgin/master - not something we can merge

I tried it many times, read other posts, restarted the section, etc., and it did not help.

Here, copy and pasted it. I don't know how to do a screen shot, sorry.

$ cd my-quizzes
$ git merge orgin/master
merge: orgin/master - not something we can merge

I tried all the things on other posts. No luck. Does someone know how to get past it?


#2

Did you try:

git fetch

before you tried to merge?


#3

I am having the same issue. Im really frustrated. Seems like my codecademy connection keeps getting lost also though my internet connection has been stable


#4

Check this post
Basically I got it to work by closing the terminal session at each new exercise section.


#5

yes, I did. Still doesn't work...
but thanks for the suggestion!


#6

Yes I tried it. I restarted the window, the terminal, the section, etc. ... still doesn't work.
thanks, though


#7

I don't know if you did this every time, but you have a typing mistake there.


#8

AHHHHH!! Dang! Thanks albionsrefuge! that solved the problem!!


#9

This was the step that I was missing. Do you always have to 'git fetch' before you can 'get merge origin/master'?


#10

I was also stuck on that exercise. Typing "git fetch" before merging seems to work for me.


#11

In real life, you would do that to make sure you had the most up-to-date data. git pull does a git fetch followed by a git merge.

In this exercise, I think that it just forgets that you've fetched in the previous exercise.


#12

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.