Getting "permission denied" have no idea why and can't proceed


#1


#2

When you write like this you try to execute .bash_profile as a program. .bash_profile doesn't have the execution permission, so that is what the error message means.

You want to open the file with a text editor instead. From what I remember it's "nano" that you use in this course.


#3

It is nano and I really got it that the error message means the program doesn't have the execution permission. And the problem is that, it isn't possible to get INTO the text editor because that has a nasty habit of dropping below the frame of the workspace.

As answers go, that wasn't terribly helpful.


#4

Well, running .bash_profile as an executable is the reason you get that error message. If you have issues with starting nano maybe your question and screenshot should have been about that instead?


#5

I'm quite aware that running bash_profile as an executable is the reason I got the error message.

As evidenced by the fact that I COULD GET an error message, the problem is not with starting nano, but with getting into the editorial space to perform any actions AFTER starting.
The reason the screen shot looks as it does is that was the ONLY thing visible. I would be happy to provide a screenshot of that so you can see what I mean.


#6

Yes please. I would like to see what you mean.


#7

So, you enter

$ nano ~/.bash_profile

and nothing happens / it exits? If that's the case something is really wrong with the exercise/system. But I'm not sure how your original question was related to that..


#8

this, as you can see, is full-screen. And it is not possible to access any of the commands at the bottom of the page. Not only that, but the side menu has a really nasty habit of losing the slider so it is impossible to move up or down to see previous text. In order to obtain the slider, it is necessary to resize the screen. It has happened more than once that doing that results in the disappearance of whatever had been entered on the screen.


#9

I can reproduce the problem with Firefox on OS X. The good news is that even though you can't see the list of commands at the bottom, you can still perform the keystrokes necessary to save the file and exit from nano.

I just filled out the Report a Bug form in that exercise to let them know about this problem. If you have time, you should do that too.


#10

Right. In theory. However, as I said, the 2nd part of the problem is that the slider (on the right side of the instruction panel) DISAPPEARS ENTIRELY, and can only be obtained by RESIZING THE BROWSER, which then causes ALL DATA to vanish. COMPLETELY. which means that whatever was there is gone, and not re-obtainable. And, as a extra bit of fun, the slider then vanishes again once the browser has been resized, which means that getting access to whatever was sought from the instruction panel is now, basically pointless since all data from the exercise has disappeared.


#11

and things are now getting SO much more amusing. went back to restart #2. Again. for the I'm not sure how many-th time.

entered nano ~/.bash_profile.
got to step 2 (had to resize the browser screen to get access to the slider on the instruction panel). entered "Welcome, etc", then command o. entered a file name. pressed enter. then command x. then "clear" (and had to resize the browser screen at each step to be able to see the edit line.

then: nothing. Nada, nichivo. rien. clum. bupkus.

Step 3 not active. at all.

However, I went ahead and entered "source ~/.bash_profile and got..."file not found."


#12

Looks like you're running a Mac ?


#13

and now things are getting fun in a not-at-all kind of way. Changing browsers to Safari resulted in Codeacademy crashing completely AND making my system freeze to the point that I had to shut down (so no screenshot--I took one, but Preview wouldn't open to let me double-check to see how much I had captured).

And because I couldn't do ANYTHING at all, it was impossible to leave a bug report.

I restarted the computer, still in Safari, and through steps 1 and 2 (I think, because even in Safari, while edit commands at the bottom of the screen are visible, the slider for the instruction panel disappears. Unlike Firefox. however, resizing the browser screen in Safari does NOT restore the slider, so it was impossible to see if step 3 had been highlighted.

I could only infer it from the red outlined box at the bottom of the screen which demanded that I enter the source command for the file. However, since that part of the instruction panel was unavailable because the slider had ceased to exist, I was unable to obtain the command structure to execute that command.

this is really fun in a not-by-any-stretch-of-the-imagination kind of way.
and here is a screenshot of the workspace, with the instruction panel at step 2, step 3 is not available because the slider does not exist, and a demand at the bottom of the screen that I execute a command whose structure is unavailable because there is no way to access the necessary information:


#14

http://giphy.com/gifs/the-it-crowd-chris-odowd-F7yLXA5fJ5sLC


#15

Having gotten out of 2 and back into 3 (not sure how or why), I am once again where all of this started: entered ~/.bash_profile and got "permission denied." Again.

However, as you can see, despite "permission denied," and despite the fact that the greeting I entered did NOT come up on the screen, I WAS continued on to step 2--which was pretty pointless since, on entering "alias pd="pwd" absoultely NOTHING happened:


#16

As we can see, "~/.bash_profile" accomplished nothing but "pemission denied."
entering "alias pd="pwd" also did nothing at all.

going back to "source ~/.bash_profile" recalled the greeting I had entered.
"alias pd=pwd", however, resulted in NOTHING.

not only that, but command O did NOT save anything, and command x did NOT exit the program.

and, to make things even more fun (as if they couldn't be already), the slider on the information panel is, as always, unavailable unless the browser is resized.


#17

the answer to the problem of "permission denied" was simple: type "nano ~/.bash_profile"

the problem was that because the slider on the information panel disappeared (unless the browser was resized), it was impossible to know what command was missing.

and because resizing the browser meant losing any data that had been inputted, it was impossible to resume entering code once the information had been located.


#18

I also get the same problems like you all do. I'm currently filling out a bug report for this. I even tried to complete the last two steps but it didn't do what it was supposed to do. I was enjoying this course until these bugs had to ruin it :frowning:


#19

Maybe you're using a small monitor? I'm using a 15.6" laptop and I can see ALL of the commands on the bottom. Maybe it's not a big bug, probably just a small bug for small screens.


#20

Ahhh Emma, I've been busy today and missing all of this -- that sounds like a terrible experience. I haven't had a chance to read it all, and I haven't tried using Safari yet, but I will tell you that I've been using Chrome and I don't see any of these issues.

I'm going to try Safari as soon as I can find my password, grrr. :smile: