General Nerdiness Questions

I’ve got two questions that are (admittely) well-beyond my current learning level ,but hey that’s how I roll.

Q1: I use VSCode and when I run my code it just scrolls off the top of the output widow. In addition to being nerdy, I tend a little toward CDO (OCD in the correct letter order) and want my screen clear; so, I’m force to click the ‘clear output’. I know a trick that works in the cmd terminal, but would like to have a code snippet I could plop in and do it programatically as I go through the courses. (Something like the builtin editor does when we ‘save’.)

Q2: Every so often we well get characters in the projects that are not ASCII format that include the umlauts, accents, tilde and such (UTF-8 I believe). How do I force display in the output of these various diacritics?

TIA for indulging my eccentricities so early in my learning.

TBH, your eccentricities are of no concern to us. In fact none of what you go through from day to day matters a tinkers nail. We deal with code and learning code. Don’t make this about you.

Check out this question on StackOverflow for a good answer.

Then stop create code problems that fail.

image

I appreciate that, but I’m not looking to convert a file. I’m looking to have VSCode properly render beyond 128th character.

By example, this lesson has a small letter e with acute (é) in the painting named Vétheuil in the Fog.

I had done some searching and thought I found a solution by including # coding=UTF-8 at the beginning of the python code. Alas, that didn’t work and the character is still misrepresented with a placeholder (�).

This is about a coding solution to problems.

And, OF COURSE, it’s about me. It’s about me wanting to learn CODE to deal with my CODE.

If you are on Windows 10, you should be able to fix this in the settings.

Go to your regional settings, scroll down to “Related settings” and click “Additional date, time & regional settings”:

Then click on Region again:
image

Then go to the “Administrative” tab and click “Change system locale…”:

You should see an option to use the Beta feature that makes Windows use Unicode UTF-8:
image

Select that and hit OK, then Apply.

You should be good to go.

3 Likes

You are a godsend. TY TY TY

1 Like