For section Entitled: Conditions and Control Flow, When I Hit "Run" Computer Freezes And Prints The Result 5 Times!


#1

For the section entitled: Conditions and Control Flow, when I hit “Run” as told by the instructions, the computer freezes and prints the out below 5 times!

You’ve just entered the clinic!
Do you take the door on the left or the right?
Type left or right and hit ‘Enter’.You didn’t pick left or right! Try again.

And then I’m unable to hit the “next” button to move onto the next exercise! What is causing this? Is there a bug in this exercise? Thanks in advance for your help!


#2

can we see your code?


#3

The code was given by Codecademy, all they instructed me to do is to hit “Run”

def clinic():
    print "You've just entered the clinic!"
    print "Do you take the door on the left or the right?"
    answer = raw_input("Type left or right and hit 'Enter'.").lower()
    if answer == "left" or answer == "l":
      print "This is the Verbal Abuse Room, you heap of parrot droppings!"
    elif answer == "right" or answer == "r":
      print "Of course this is the Argument Room, I've told you that already!"
    else:
      print "You didn't pick left or right! Try again."
      clinic()

clinic()

#4

working fine? It should recognize left or right input. Make sure to include no additional characters (like spaces)


#5

Screenshot


#6

so you can’t enter anything? You might want to reset the exercise and refresh the page several times


#7

did that…still same problem


#8

Just done a test on a few lessons using the Codecademy editor.

Asking for input isn’t working for me either, despite my code being fine if I run it locally.

I think it might be a bug with the interface, so I’ve reported it through the link in the bottom-left panel of the lesson.

Hopefully it’ll be reviewed soon. :slight_smile:


#9

thanks for the confirmation!


#10

Aside

It seems to be an intermittent problem relating to raw_input. The generalized workaround in these instances is to comment the line and set the variable manually.

I have not tested input, as an alternative, but would be happy to once we have a link to the exercise. Please post same in a reply. Thanks.


#11

I tried both when I tried to replicate the problem, neither worked. :slight_smile:


#12

seems like the bug has been fixed…finally I was prompted with the “next” button


#13

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.