[Fixed] Can’t indent using tab key in code editor

Hi, i had the same problem as timmysavage and I tried your solution but it did not work. Still, when I pressing the tab button inside the code editor in code academy it doesn’t indent the text. However, the cursor moves from the code editor to the preview window in safari, which is pretty annoying while I’m trying to code. It worked fine yesterday, but it suddenly changed today. Do you have any tips of what I could do to fix it?

1 Like

Same thing happening for me now.
It was working fine this morning. Now when I press tab, it is focusing on url field.
Tried the steps that you mentioned but nothing happens when I select “Toggle Tab Key Moves Focus”.


@net3959582184 @design8521863073 thank you very much for bringing this to our attention.

I notified Codecademy about this bug, investigation is in progress. I decided to move our posts to a new discussion to make it easier for us to track this bug report.

I will keep you updated. Thanks again :slight_smile:

1 Like

just FYI… it is working again :slight_smile:

I have tried this, but it still the focus moves from the code editor to the preview window…
And now when I press F1 key in the code editor nothing happens.

Okay so it suddenly just start working out of nowhere. I just pressed all the F buttons (F1,F2,etc) at it worked. Like I said I don’t know what caused it to work but at least you could give it a try and see if it works:)

lol, same thing for me.
Yesterday I tried messing with the F keys, as well as cleaning cache, restarting computer, but nothing made it work so I just gave up.
Today it was working again. I guess they squashed a few bugs on their end :slight_smile:

1 Like

Codecademy managed to fix this bug. Tab key should work correctly in the editor.

Thank you again for bringing this to our attention. Bug status changed to fixed.