[fixed #90, #66, #140] Ruby on Rails file editing and saving issue


#1

In the Ruby on Rails course, Saving Data section, I opened the routes.rb file to make the changes per the instructions. I then selected the messages_controller.rb file to make the edits there.

When I went back to the routes.rb file, the recently edited contents of this file was overwritten and replaced by all the identical content from the messages_controller.rb file. I

I have already 1) refreshed the page, 2) logged out and then back in, 3) closed all the files and reopened them and 4) used the "Get help -> I want to restart this exercise" to reset all the files. None of these fixed the issue.

I'm using Chrome Version 48.0.2564.116 (64-bit) on a MacBook Air 13.3.

Any help would be greatly appreciated.

Jeremy


#2

Hey Jeremy,

Thanks for reporting this! We've got a bug report filed, so it shouldn't be too long before this is fixed :slightly_smiling:


#3

Hi,

Any update on when this may be fixed?

Thanks!
Jeremy


#4

@teramaster40145 Unfortunately not yet :confused:
I'll try to update here once Codecademy gets it fixed though :slight_smile:


#5

Hi - Wondering about the fix here - any update?
Also, is this an issue in the free version of Codecademy or is it also an issue in the paid version? I want to sign up for the pro version but I'm reluctant because this bug is blocking me in the free version and I'm concerned I'd be wasting money if I can't progress through this level.

Thank you,
Jeremy


#6

@teramaster40145 Thanks for asking! I completely forgot about this, really sorry about that :confused:

This is allegedly fixed, according to the bug report. Are you able to take a screencast or several screenshots of you demonstrating the issue?

Also, could you answer:

  • Which browser are you using?
  • Are you behind a firewall?
  • Are you using an adblocker?
  • Which operating system are you using?
  • Are you behind a school/company network?

The more information/details I have, the easier it will be for the Codecademy engineers to be able to find the problem and fix it :slight_smile:

Since they both use the same editor, I assume you'll have this problem regardless of whether you go Pro :confused:


#7

This issue appears to have been resolved. There is another bug in the browser when visiting http://localhost:8000/messages which I have opened a separate ticket for.

Thank you for the help closing this one out.