Fix for "Your first program" dropdown not toggling


#1

Continuing the discussion from Your first program: on Try it out:

Learners going through this part of the course have been running into trouble with the dropdown menu not appearing. Why? Codecademy moved the site to HTTPS, but the resources you need to load there aren't HTTPS, so to protect you, your browser won't load them.

The fix is simple. Copy/paste each link into a new tab, see where it goes, copy that and replace the http:// at the beginning with https://. To save you time though, these are the links you need to copy :slightly_smiling::

https://ajax.googleapis.com/ajax/libs/jquery/1.11.1/jquery.min.js
https://s3.amazonaws.com/codecademy-content/courses/ltp2/js/yfp/app.js

or, for easier copying:

https://ajax.googleapis.com/ajax/libs/jquery/1.11.1/jquery.min.js
https://s3.amazonaws.com/codecademy-content/courses/ltp2/js/yfp/app.js

Your first program: on Try it out
#2

#3

Still doesn't work for me. Seems to be a missing semicolon in the script. I added in another script section with the semicolon and then it worked.


#4

Yeah it doesnt work for me neither.

unfortunately.
this is the code I have:

var main = function() {
$('.dropdown-toggle').click(function() {
$('.dropdown-menu').toggle();
});
}
$(document).ready(function);

Thanks a lot!


#5

@gigawhiz92346 Could I see your HTML code, if you go back one step from where you copy/pasted your JS code?