Film finder project

In the project film finder. I am not getting response back from the API. I have even used the try it out section on the API website, and it gave Network Error on every try. I have tried different API endpoint but still Network Error. I am stuck on this part of the project.

1 Like

Hi! I just finished the film finder project. I’m not really good at coding but I didn’t have problems at all.
You just need to be careful to follow the steps. Everything we need, written up there.
Oh, and you might want to check at the very first line of “script.js”. Are you sure that your tmbdKey is set equal to your API Key? Everytime you hit “reset projects button”, it goes blank.
And you also might want to put your codes up there next time otherwise we are not sure how to help you.
Happy coding :slightly_smiling_face:

1 Like

Thanks, I was able to fix it. I didn’t have the no cache object and I was missing a slash in url

1 Like

Good to hear that :smiley: Happy coding!!!

Hi!

I am not sure which part of the of your project you were on but, did you manually add a missing slash? That is odd because the code should render the url “correctly” as seen below. The movie solution show no cache object.

My project works correctly until inside of getMovieInfo on the fetch(urlToFetch) for similar reasons regarding the API . If I enter the url into the web browser it results in:
{“success”:false,“status_code”:34,“status_message”:“The resource you requested could not be found.”}
Which suggests the code is NOT rendering the movieId correctly in the url.

What the console.log(urlToFetch) look like in your getMovieInfo function?

From getMovieInfo function:

  let urlToFetch = `${tmdbBaseUrl}${movieEndpoint}${requestParams}`;

  console.log(`In getMovieInfo: url = ${urlToFetch}`);

//api.themoviedb.org/3/movie/508947/?api_key=xxxx

Hi Folks,

I’m having trouble and even tried submitting the EXACT code from the helper vid.
I am receiving the following message when attempting to fetch:

“Cross-Origin Read Blocking (CORB) blocked cross-origin response https://rum.browser-intake-datadoghq.com/api/v2/rum?ddsource=browser&ddtags=sdk_version%3A4.4.0%2Cenv%3Aproduction%2Cservice%3ACodecademy-production%2Cversion%3A2b56380c&dd-api-key=pub4b4c157b8033dcd97e14c779a3ca222c&dd-evp-origin-version=4.4.0&dd-evp-origin=browser&dd-request-id=a0e10c21-a60d-4e54-8e8b-4b122274b12e&batch_time=1651686877721 with MIME type application/json.”

Any insights are apreciated,
Thanks,
Dave

What is the no cache object?

Hi,
I am having the same problem with the request “Cross-Origin Read Blocking (CORB) blocked cross-origin response"
Did you manage to fix this problem? any advice/help, please.

Blocking (CORB) blocked cross-origin response https://rum.browser-intake-datadoghq.com/api/v2/rum?ddsource=browser&ddtags=sdk_version%3A4.4.0%2Cenv%3Aproduction%2Cservice%3ACodecademy-production%2Cversion%3A7c04d1d7&dd-api-key=pub4b4c157b8033dcd97e14c779a3ca222c&dd-evp-origin-version=4.4.0&dd-evp-origin=browser&dd-request-id=48a2d732-0d29-48b1-a39e-286e6c66a2a8&batch_time=1652357285788 with MIME type application/json. See Cross-Origin Read Blocking (CORB) - Chrome Platform Status for more details.

Hi,

Sorry, I did not see your msg till now.
The hint for step 11 says:

Blockquote
You may see error messages when you open the console. Don’t worry about those for now. We will resolve them as we continue to build out our program.
Blockquote

The CORB error was unrelated to what turned out to be a careless typo on my part. I spent a lot of time researching this to no avail.
Are you doing Full Stack?

Hi, Thank you for your reply. Yes, I am doing Full Stack but find it very challenging and hard redux. I end up getting lots of support!

It is a lot of work and a wide range of subjects. I’m about 40% through, working on jammming part 2. Keep in touch

I am on 49%
You have not done redux then!

No, I have not gotten to that yet, Fun? Something to look forward to.