Film Finder Error_getMovies

Hi I seem to be having an issues with the getMovies part of project.


I keep getting Failed to load resource: the server responded with a status of 404 (), when I console.log(jsonResponse).
Please help. I tried debugging it and it seems selectedGenre doesn’t return any response or value.

1 Like

this does not give a proper idea plz share file

https://www.codecademy.com/workspaces/6281e3994f971d6815938b4e

thanks for responding. this a link with the code

In script.js file

line modification

1 add API key
2 Remove slash after 3 ‘https://api.themoviedb.org/3/
31 after chacking json response remove console.log
31 return movies
38 remove getMovies() function call

Note
you are getting 401 error at line 10 27 becoz of url path
look at : error: https://api.themoviedb.org/3//discover/movie?api_key=&with_genres= 401

I hope it will help :)
if any dought feel free to get help thanks!

Summary

This text will be hidden

3 Likes

Thanks so much. it worked. I am so grateful.

:vulcan_salute:Nice to hear that it helped :)
by the way where are you from?
I’m from India…!
if you need any code review you can share it to me and may be you can review mine :technologist:

I am from Ghana. Surething will be happy to share and review code with you.

I had the same issue too. Thanks for this!

1 Like

Thank you, it helped)