Fatal not a git respository


#1

Hi , i did what you said to the other guy( i had the same problem) and nothing. I reported a bug too , i'm stuck a couple of days here . They say : fatal not a git respository ( or any of the parent directories):.git , after the cd personal-website & the example .
- Between 'cd personal-website' and the example i tried and put "git init" , just in case ..... but nothing . If ayone has an idea , Please help .....


4. Add the remote
#2

Are you in the right directory?
If you're in the right directory and it's not a git repository, then make it a git repository.


#3

Thanks for your responce . I'm in the right directory ( i follow the exersice step by step) , what do you mean , "make it a git resposity" ? . I tried many stuff : 1) begin with cd personal-website command , and then the example ,2) between them i put "git init" , nothing .
Thanks again , i know it is something stupidly easy , but i'm stuck .


#4

If you make assumptions like "I'm in the right directory" then you'll make simple stupid mistakes.

Verify everything.

Are you in the right directory? Which one should you be in? Which one are you in?

Is this a git repo? Try a git command to find out, like git status If not, you make it so with git init

What is the output of:

cd ~/daw/personal-website
git status
ls
jekyll serve

You should be seeing git telling you some stuff about the status of the repo, the files, and then jekyll should start hosting the website


#5

Thank you a lot my friend for your response - i'll do so


#6

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.