FAQ: Variables and Operators - Variable Types and Advanced Usage

This community-built FAQ covers the “Variable Types and Advanced Usage” exercise from the lesson “Variables and Operators”.

Paths and Courses
This exercise can be found in the following Codecademy content:

[Beta] Learn PowerShell

FAQs on the exercise Variable Types and Advanced Usage

There are currently no frequently asked questions associated with this exercise – that’s where you come in! You can contribute to this section by offering your own questions, answers, or clarifications on this exercise. Ask or answer a question by clicking reply (reply) below.

If you’ve had an “aha” moment about the concepts, formatting, syntax, or anything else with this exercise, consider sharing those insights! Teaching others and answering their questions is one of the best ways to learn and stay sharp.

Join the Discussion. Help a fellow learner on their journey.

Ask or answer a question about this exercise by clicking reply (reply) below!
You can also find further discussion and get answers to your questions over in #get-help.

Agree with a comment or answer? Like (like) to up-vote the contribution!

Need broader help or resources? Head to #get-help and #community:tips-and-resources. If you are wanting feedback or inspiration for a project, check out #project.

Looking for motivation to keep learning? Join our wider discussions in #community

Learn more about how to use this guide.

Found a bug? Report it online, or post in #community:Codecademy-Bug-Reporting

Have a question about your account or billing? Reach out to our customer support team!

None of the above? Find out where to ask other questions here!

The first thing we need to do in this lesson (create a constrained variable of type Int with the name num_1 and value 42) is not working, even if I copy the code from the hint…

[Int]$num_1 = 42


So I’m basically stuck here :sleepy:

PROBLEM (more or less) SOLVED

If I put [Int]$num_1 = 42in the first line of the script “variable_types.ps1” and run it, the first task box gets checked… bug should be solved anyways I’d say.