FAQ: Thith Meanth War! - Getting User Input

thanks for the hint, the code works in firefox!! :+1:

1 Like

Interesting!!

I usually use Firefox, but it turns out it works better (for me, that is!) on Chrome.

Anyways, I’m glad that you got it to work!

1 Like

I’ve figured out how to reliably reproduce it. For me it occurs when you don’t print anything out prior to calling gets. The console cursor blinks and looks ready, but typing and hitting enter produces no effect at all, even after a mouse click on the cursor.

Once I inserted a puts call ahead of the gets call, I was able to click on the cursor and input worked. Still seems like a bug but at least I got past the problem!

1 Like

FYI this is on Chrome, and I tested it on an older version and an updated version:

Version 83.0.4103.61 (Official Build) (64-bit)
Version 83.0.4103.97 (Official Build) (64-bit)

WOW, simply wow that this didn’t get fixed after like almost two years. Still got the same issue

Fantastic! Thank you!

1 Like

Same issue still going on on December 9, 2021.

I have tried 3 different ways and it’s still bugged…

March 28, 2022 now, still bugged. Does anyone from Codecademy see these?

Proposed clarification to this exercise: in the actual exercise question (not the hint) tell the student to enter an input in the terminal while it’s loading. That’s what the hint says, but I don’t like clicking on the hint unless I have to. If I was told in the question to input something into the terminal while it was loading I wouldn’t have had an issue.

the instruction are not very direct and what it ask for is different from the actual answer