FAQ: Static Variables and Methods - Modifying Static Variables

This community-built FAQ covers the “Modifying Static Variables” exercise from the lesson “Static Variables and Methods”.

Paths and Courses
This exercise can be found in the following Codecademy content:

Learn Java

FAQs on the exercise Modifying Static Variables

There are currently no frequently asked questions associated with this exercise – that’s where you come in! You can contribute to this section by offering your own questions, answers, or clarifications on this exercise. Ask or answer a question by clicking reply (reply) below.

If you’ve had an “aha” moment about the concepts, formatting, syntax, or anything else with this exercise, consider sharing those insights! Teaching others and answering their questions is one of the best ways to learn and stay sharp.

Join the Discussion. Help a fellow learner on their journey.

Ask or answer a question about this exercise by clicking reply (reply) below!
You can also find further discussion and get answers to your questions over in #get-help.

Agree with a comment or answer? Like (like) to up-vote the contribution!

Need broader help or resources? Head to #get-help and #community:tips-and-resources. If you are wanting feedback or inspiration for a project, check out #project.

Looking for motivation to keep learning? Join our wider discussions in #community

Learn more about how to use this guide.

Found a bug? Report it online, or post in #community:Codecademy-Bug-Reporting

Have a question about your account or billing? Reach out to our customer support team!

None of the above? Find out where to ask other questions here!

In step 1 I originaly used
numATMs++;
It seemed to work fine, but it wasn’t accepted as the right code to use. Was this just a quirk of the system that checks for correct answers, or is there some reason that “+=1” is better than “++”?

In step 2 I originally used
totalMoney += this.Money;
Again it worked fine but it wants me to use
totalMoney += inputMoney;
Again, does this make a difference - is there some reason why it’s better to use inputMoney than this.money? Although the results are the same in practice, it seems slightly neater to me to define totalMoney according to the money value in each ATM, rather than the inputMoney. (Or even better, to have a separate method to set totalMoney according to the sum of money in each ATM, rather than increasing and decreasing it with deposits and withdrawals.)

1 Like