FAQ: Setting up a Server with HTTP - Routing

This community-built FAQ covers the “Routing” exercise from the lesson “Setting up a Server with HTTP”.

Paths and Courses
This exercise can be found in the following Codecademy content:

Learn Node.js

FAQs on the exercise Routing

There are currently no frequently asked questions associated with this exercise – that’s where you come in! You can contribute to this section by offering your own questions, answers, or clarifications on this exercise. Ask or answer a question by clicking reply (reply) below.

If you’ve had an “aha” moment about the concepts, formatting, syntax, or anything else with this exercise, consider sharing those insights! Teaching others and answering their questions is one of the best ways to learn and stay sharp.

Join the Discussion. Help a fellow learner on their journey.

Ask or answer a question about this exercise by clicking reply (reply) below!
You can also find further discussion and get answers to your questions over in #get-help.

Agree with a comment or answer? Like (like) to up-vote the contribution!

Need broader help or resources? Head to #get-help and #community:tips-and-resources. If you are wanting feedback or inspiration for a project, check out #project.

Looking for motivation to keep learning? Join our wider discussions in #community

Learn more about how to use this guide.

Found a bug? Report it online, or post in #community:Codecademy-Bug-Reporting

Have a question about your account or billing? Reach out to our customer support team!

None of the above? Find out where to ask other questions here!

I am getting the following error message after running $ node app.js

shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
internal/bootstrap/switches/does_own_process_state.js:130
    cachedCwd = rawMethods.cwd();
                           ^

Error: ENOENT: no such file or directory, uv_cwd
    at process.wrappedCwd [as cwd] (internal/bootstrap/switches/does_own_process_state.js:130:28)
    at Object.resolve (path.js:1072:47)
    at resolveMainPath (internal/modules/run_main.js:16:40)
    at Function.executeUserEntryPoint [as runMain] (internal/modules/run_main.js:70:24)
    at internal/main/run_main_module.js:17:47 {
  errno: -2,
  code: 'ENOENT',
  syscall: 'uv_cwd'
}

I get the same error message too, even though my code is the same as the solution. Seems that there is a bug that they need to fix it.

It will only work when I click 'Replace with solution’ button.

1 Like

I have the same error, I don’t know why…

1 Like

I am stuck with the step 5 in ROUTING . After I run the codes and then click the ‘check work’ button, there is nothing but only the busy animation on the square box before the “5.”. This can keep occurring numerous times. I shut the course and reopen it, but the issue persists.

So this thread was first opened in July 2021, nearly a year later I’m also having this same issue.

as a new user for a service that charges ~500 a year I gotta say I’m not too impressed.

I’m also having the same issue with step 5 in Routing. My solution is identical to the given solution, but will only work if I use their solution

const handleGetRequest = (req, res) => {
  const pathname = req.url;

  if (pathname === '/users') {
    res.end(JSON.stringify([]));
  }
}

This is the solution of the 4th ex. Pathname is only part of the URL why we assign full url to pathname?
PS: because req.url is the pathname part of url.!

Ok then I have another question))
Why in this part

function handleGetRequest(req, res) {
  const { pathname } = new URL(req.url);
  let data = {};
 
  if (pathname === '/projects') {
    data = await getProjects();
    res.setHeader('Content-Type', 'application/json');
    return res.end(JSON.stringify(data));
  }
 
  res.statusCode = 404;
  return res.end('Requested resource does not exist');
 
}

we use const { pathname } = new URL(req.url);
It’s wrong req.url - it’s only path of the url. And we get an error TypeError [ERR_INVALID_URL]: Invalid URL