FAQ: Redirection - grep I

This community-built FAQ covers the “grep I” exercise from the lesson “Redirection”.

Paths and Courses
This exercise can be found in the following Codecademy content:

Web Development

Learn the Command Line

FAQs on the exercise grep I

Join the Discussion. Help a fellow learner on their journey.

Ask or answer a question about this exercise by clicking reply (reply) below!

Agree with a comment or answer? Like (like) to up-vote the contribution!

Need broader help or resources? Head here.

Looking for motivation to keep learning? Join our wider discussions.

Learn more about how to use this guide.

Found a bug? Report it!

Have a question about your account or billing? Reach out to our customer support team!

None of the above? Find out where to ask other questions here!

I’m unsure why I am failing this?



OK, I added the file to the direction and still no luck?

Why does the “Learn The Command Line” exercises not have a way to escape the exercises with the Get Solution can do for you when things bug out?

Ok, found the get solution part to bypass this. Disregard.

1 Like

Hi Bro!

I had the same problem… try to write “Ar-C-tic”

grep -R Arctic /home/ccuser/workspace/geography

1 Like

I type this verbatim but it still doesn’t work, I think this could be bugged.

I believe there is still a bug as I have the same problem and I have reviewed it many times and I cannot see where is the issue. Could you pls help?

Note that I have typed the command as instructed but still the Codecademy marks it as an error with the message “Type the command after the shell prompt”

Hey, @net7386409558. You are close, but you do have a typo in your command. Look closely at how you spelled Arctic.

Hello, @ultrasonoro! Look closely at how you spelled Arctic.

I was getting the same problem for a while until I realized that it isn’t R1 (R-one), but it is Rl (R-L). Hopefully that’ll help.

1 Like

I did a copy/paste of the code in #1 and discovered there was an extra space at the end of the command. Pasted that into bash, hit enter and bam! four lines of text came out.

I have also been having problems with this page.

I have typed in the prompt and copied and pasted the prompt. I still get the “Type the command after the shell prompt.” Error.

it should be arctic … you have typed artic