FAQ: React Router - Installing React Router


This community-built FAQ covers the “Installing React Router” exercise from the lesson “React Router”.

Paths and Courses
This exercise can be found in the following Codecademy content:

React Router
Learn React Router

FAQs on the exercise Installing React Router

There are currently no frequently asked questions associated with this exercise – that’s where you come in! You can contribute to this section by offering your own questions, answers, or clarifications on this exercise. Ask or answer a question by clicking reply (reply) below.

If you’ve had an “aha” moment about the concepts, formatting, syntax, or anything else with this exercise, consider sharing those insights! Teaching others and answering their questions is one of the best ways to learn and stay sharp.

Join the Discussion. Help a fellow learner on their journey.

Ask or answer a question about this exercise by clicking reply (reply) below!
You can also find further discussion and get answers to your questions over in #get-help.

Agree with a comment or answer? Like (like) to up-vote the contribution!

Need broader help or resources? Head to #get-help and #community:tips-and-resources. If you are wanting feedback or inspiration for a project, check out #project.

Looking for motivation to keep learning? Join our wider discussions in #community

Learn more about how to use this guide.

Found a bug? Report it online, or post in #community:Codecademy-Bug-Reporting

Have a question about your account or billing? Reach out to our customer support team!

None of the above? Find out where to ask other questions here!


I’ve been trying for days to get started on the react router lesson, but I cant get it to install. It seems the ‘react-router-dom’ component has been depracated, as per the message. I’ve tried this on a new application without copying the source files and the error is still the same.
I followed the directions exactly using ‘npm install --save [email protected]
There is a tutorial on the react router site, but it might not prepare me for the following depracated exercises.

Is there a fix for this? There’s no walkthrough and the solution produces the same error. As is, it’s an utterly pointless lesson. Is there a complaints procedure?