FAQ: React Router - Installing React Router

This community-built FAQ covers the “Installing React Router” exercise from the lesson “React Router”.

Paths and Courses
This exercise can be found in the following Codecademy content:

React Router
(Beta) Learn React Router

FAQs on the exercise Installing React Router

There are currently no frequently asked questions associated with this exercise – that’s where you come in! You can contribute to this section by offering your own questions, answers, or clarifications on this exercise. Ask or answer a question by clicking reply (reply) below.

If you’ve had an “aha” moment about the concepts, formatting, syntax, or anything else with this exercise, consider sharing those insights! Teaching others and answering their questions is one of the best ways to learn and stay sharp.

Join the Discussion. Help a fellow learner on their journey.

Ask or answer a question about this exercise by clicking reply (reply) below!
You can also find further discussion and get answers to your questions over in Language Help.

Agree with a comment or answer? Like (like) to up-vote the contribution!

Need broader help or resources? Head to Language Help and Tips and Resources. If you are wanting feedback or inspiration for a project, check out Projects.

Looking for motivation to keep learning? Join our wider discussions in Community

Learn more about how to use this guide.

Found a bug? Report it online, or post in Bug Reporting

Have a question about your account or billing? Reach out to our customer support team!

None of the above? Find out where to ask other questions here!

Upon following the tutorial steps, we are met with this error:

Failed to compile

./src/components/Search.jsAttempted import error: 'useHistory' is not exported from 'react-router-dom'.

It seems that in react-router-dom v6 useHistory() is replaced by useNavigate() . (source)

Replacing instances of useHistory() with useNavigate() seems to do the trick.

Similarly, useRouteMatch needs to be replaced with useMatch.

It would be good for the downloadable code package to be updated for others using this lesson.


Following issues with further sections because of the outdated version of React Router used in this tutorial, I manually updated package,json to use the old version so that I could continue the course.

"react-router-dom": "^5.2.0",

For anybody stranded when trying to start the live server with npm start.

In your package.json: change this line

"start": "react-scripts start"


"start": "react-scripts --openssl-legacy-provider start"

Please note that this is only recommended as a temporary fix for this exercise. I would not recommend this when working on a professional project as you are most certainly running with a known insecure SSL.



Your trick almost worked…

I got this error:

Failed to compile
./src/index.js 1:52
Module parse failed: Unexpected token (1:52)
File was processed with these loaders:
 * ./node_modules/@pmmmwh/react-refresh-webpack-plugin/loader/index.js
 * ./node_modules/babel-loader/lib/index.js
You may need an additional loader to handle the result of these loaders.
> $RefreshRuntime$ = require('C:/react-router-lesson-starter/node_modules/react-refresh/runtime.js');
| $RefreshSetup$(module.id);

At this point, rather than trying to configure webpack to work with an outdated version of react router, I would instead just check out the docs on the react router page and see if you can build the same simple app with the new version. The differences aren’t huge. They have clearly written documentation and a tutorial.

1 Like

Exactly what I’ve done, thank you!

The fact that this exercise has been broken for 8 months now and nobody on the Codecademy team has reviewed the exercise to work with the latest version of React Router seems just lazy. I’m paying the pro subscription and putting my trust in the academic team to teach me up to date content. I know as a developer we will have to do work arounds a lot of times to get outdated software to run, but the fact that y’all know it and won’t even want to fix it is lazy. It’s not an unknown bug and just adding a disclaimer at the top of the exercise with the official documentation instead of just reviewing your exercise is just lazy.


Thanks so much! This worked for me!

Thanks Passenger89.

That works and allow me to continue with the project :slight_smile:

Worked here thank you

This is the third example in what is probably a long list of reasons why their React course needs an entire re-write. Is that in the works?


This project has been out of date for over a year. If I wasn’t two thirds of the way through your front-end development course, I would seriously consider taking my learning elsewhere. As @mreed4 said, this is at least the 3rd example in your react course that needs to be updated.

To everyone seeking help on this project: do yourself a favor and just do the tutorial project on the official React Router website.

The info will be up to date and your project will actually run (what a concept)!

CodeCademy: get it together.


Before starting I thought I’d come to the forum first and see what people are experiencing having read the disclaimers in each exercise :sweat_smile:

CodeCademy actually replied to one of the threads I’m on and they’re saying that the whole React content is being updated for hopefully an early April release - https://discuss.codecademy.com/t/front-end-development-authorization-form/733330/8?u=rswainson


I would also like to recommend this video. It’s easier to understand than the tutorial from the official website.

Im on step 2 task 2 and already having problems. I unzipped the file, opened it in VS Code, clicked package.JSON and opened my terminal entering the command given → npm install react-router-dom --save and it never appears in my dependencies. Anyone else have this problem?

Im paying for Pro but this whole react section seems to be full of problems.

hi giga !
i think you missed something important, you should install router v5 as mentioned in step 2 :

npm install --save [email protected]

then after as mentioned by passenger89 earlier, modify your “package.json” to fix starting the application bug.

It worked for me.

Thanks! Actually I installed the router v5 though I didn’t mention it in my post. However I didn’t modify the package.json as mentioned by passenger89. that made the difference! thanks a bunch

Hi folks !
I just realized that @Codecademy had release a new version of the React Router V6 courses ! But strangely, they didn’t notifyied about that and also they didn’t replaced the old version in my pro FS skill path :confused:
But they just communicated they will replace react lessons next week !

More informations here:
Web Development Change Log | Codecademy