FAQ: Putting the Form in Formatter - Printing the Output


#1

This community-built FAQ covers the “Printing the Output” exercise from the lesson “Putting the Form in Formatter”.

Paths and Courses
This exercise can be found in the following Codecademy content:

Learn Ruby

FAQs on the exercise Printing the Output

There are currently no frequently asked questions associated with this exercise – that’s where you come in! You can contribute to this section by offering your own questions, answers, or clarifications on this exercise. Ask or answer a question by clicking reply (reply) below.

If you’ve had an “aha” moment about the concepts, formatting, syntax, or anything else with this exercise, consider sharing those insights! Teaching others and answering their questions is one of the best ways to learn and stay sharp.

Join the Discussion. Help a fellow learner on their journey.

Ask or answer a question about this exercise by clicking reply (reply) below!

Agree with a comment or answer? Like (like) to up-vote the contribution!

Need broader help or resources? Head here.

Looking for motivation to keep learning? Join our wider discussions.

Learn more about how to use this guide.

Found a bug? Report it!

Have a question about your account or billing? Reach out to our customer support team!

None of the above? Find out where to ask other questions here!


#2

Hi mates, dont understand that … it dont run normally.
thx


#3

ok, yeah i have the same issue.
my code looks as such:

print "What’s your first name? "
first_name = gets.chomp

print "What’s your last name? "
last_name = gets.chomp

print "What city are you from? "
city = gets.chomp

print "What state is that city in? "
state = gets.chomp

puts “Your name is #{first_name} #{last_name}, and I’m from #{city}, #{state.upcase}.”

and when i run the program it places the first question by itself and works properly, but the moment i answer it and press return, all off my other code gets executed at once and only the answer to the state question works.

i have tried using puts as opposed to print and the result is the same.


#4

I’m having similar problems. I think the exercises are just a little buggy. If I refresh the page, it usually starts working again - if not, I just keep refreshing until it works.